aboutsummaryrefslogtreecommitdiff
path: root/python
diff options
context:
space:
mode:
authorArn0 <yth@ythogtha.org>2023-06-09 14:59:35 +0200
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-06-17 07:39:30 +0700
commit98f7ef6b7f9c906814617fa599c01dd1d2e77c9a (patch)
tree6752f2f1f0075c217f841dbf0845c21d3f6ef33e /python
parentc52ac3cba63d7afa82c19f6cf00e31ccd3e73fd4 (diff)
python/python3-dulwich: fix wrong build using updated setuptools
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-dulwich/python3-dulwich.SlackBuild6
-rw-r--r--python/python3-dulwich/python3-dulwich.info2
2 files changed, 3 insertions, 5 deletions
diff --git a/python/python3-dulwich/python3-dulwich.SlackBuild b/python/python3-dulwich/python3-dulwich.SlackBuild
index d117a02375e4..b1afedd108b3 100644
--- a/python/python3-dulwich/python3-dulwich.SlackBuild
+++ b/python/python3-dulwich/python3-dulwich.SlackBuild
@@ -28,7 +28,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-dulwich
SRCNAM=${PRGNAM#python3-*}
VERSION=${VERSION:-0.21.5}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -40,9 +40,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -67,6 +64,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+export PYTHONPATH=/opt/python3.9/site-packages/
python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
diff --git a/python/python3-dulwich/python3-dulwich.info b/python/python3-dulwich/python3-dulwich.info
index 5c12c4d792bf..b6e34e4ebd3e 100644
--- a/python/python3-dulwich/python3-dulwich.info
+++ b/python/python3-dulwich/python3-dulwich.info
@@ -5,6 +5,6 @@ DOWNLOAD="https://pypi.python.org/packages/source/d/dulwich/dulwich-0.21.5.tar.g
MD5SUM="08b553a524041741604d0f5f9a45cd3d"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="python3-setuptools-opt"
MAINTAINER="Yth - Arnaud"
EMAIL="yth@ythogtha.org"