aboutsummaryrefslogtreecommitdiff
path: root/python
diff options
context:
space:
mode:
authorYth - Arnaud <yth@ythogtha.org>2023-07-29 07:39:29 +0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-07-29 07:39:29 +0700
commit5c50b1e46656898ed92a2786885c0cd49c504054 (patch)
tree4cd308deb4d5992bba62ffebe77161aa85ed3599 /python
parentc422fc9f7f1bcde93bf03864843230f17a67f0e1 (diff)
downloadslackbuilds-5c50b1e46656898ed92a2786885c0cd49c504054.tar.xz
python/python3-publicsuffix2: Added (Python Module).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-publicsuffix2/README12
-rw-r--r--python/python3-publicsuffix2/python3-publicsuffix2.SlackBuild74
-rw-r--r--python/python3-publicsuffix2/python3-publicsuffix2.info10
-rw-r--r--python/python3-publicsuffix2/slack-desc19
4 files changed, 115 insertions, 0 deletions
diff --git a/python/python3-publicsuffix2/README b/python/python3-publicsuffix2/README
new file mode 100644
index 000000000000..c87786ad8121
--- /dev/null
+++ b/python/python3-publicsuffix2/README
@@ -0,0 +1,12 @@
+Get a public suffix for a domain name using the Public Suffix List.
+Forked from and using the same API as the publicsuffix package.
+
+This module allows you to get the public suffix, as well as the
+registrable domain, of a domain name using the Public Suffix List
+from http://publicsuffix.org
+
+A public suffix is a domain suffix under which you can register domain
+names, or under which the suffix owner does not control the subdomains
+Some examples of public suffixes in the former example are “.com”,
+“.co.uk” and “pvt.k12.wy.us”; examples of the latter case are
+“github.io” and “blogspot.com”.
diff --git a/python/python3-publicsuffix2/python3-publicsuffix2.SlackBuild b/python/python3-publicsuffix2/python3-publicsuffix2.SlackBuild
new file mode 100644
index 000000000000..236caad20dec
--- /dev/null
+++ b/python/python3-publicsuffix2/python3-publicsuffix2.SlackBuild
@@ -0,0 +1,74 @@
+#!/bin/bash
+
+# Slackware build script for python3-publicsuffix2
+
+# Copyright 2023 Yth | Pont-en-Royans, France | yth@ythogtha.org
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-publicsuffix2
+SRCNAM=${PRGNAM#python3-*}
+VERSION=${VERSION:-2.20191221}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.?z*
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) -exec chmod 755 {} \; -o \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a [A-Z][A-Z]* $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-publicsuffix2/python3-publicsuffix2.info b/python/python3-publicsuffix2/python3-publicsuffix2.info
new file mode 100644
index 000000000000..eaf30ac9195f
--- /dev/null
+++ b/python/python3-publicsuffix2/python3-publicsuffix2.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-publicsuffix2"
+VERSION="2.20191221"
+HOMEPAGE="https://github.com/nexb/python-publicsuffix2"
+DOWNLOAD="https://pypi.python.org/packages/source/p/publicsuffix2/publicsuffix2-2.20191221.tar.gz"
+MD5SUM="6983c3a76459487056aa1334d174d6de"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Yth - Arnaud"
+EMAIL="yth@ythogtha.org"
diff --git a/python/python3-publicsuffix2/slack-desc b/python/python3-publicsuffix2/slack-desc
new file mode 100644
index 000000000000..7f71a8a46816
--- /dev/null
+++ b/python/python3-publicsuffix2/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-publicsuffix2: python3-publicsuffix2 (Get a public suffix for a domain name)
+python3-publicsuffix2:
+python3-publicsuffix2: This module allows you to get the public suffix, as well as the
+python3-publicsuffix2: registrable domain, of a domain name using the Public Suffix List
+python3-publicsuffix2: from http://publicsuffix.org
+python3-publicsuffix2:
+python3-publicsuffix2:
+python3-publicsuffix2:
+python3-publicsuffix2:
+python3-publicsuffix2:
+python3-publicsuffix2: