aboutsummaryrefslogtreecommitdiff
path: root/python
diff options
context:
space:
mode:
authorDave Woodfall <dave@slackbuilds.org>2021-05-21 21:32:21 +0100
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2021-06-02 01:02:27 +0700
commit242d6b588942a40f30ebacc9d7c326740dca9446 (patch)
treed6a46726323fad11c44147a81aa6b60a0dc91509 /python
parent4fb0c197365da73e8147b96d78fc024d1b90bbf2 (diff)
downloadslackbuilds-242d6b588942a40f30ebacc9d7c326740dca9446.tar.xz
python/pytest-runner: Convert python to python2.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/pytest-runner/=1.15.0]0
-rw-r--r--python/pytest-runner/pytest-runner.SlackBuild9
2 files changed, 3 insertions, 6 deletions
diff --git a/python/pytest-runner/=1.15.0] b/python/pytest-runner/=1.15.0]
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/python/pytest-runner/=1.15.0]
diff --git a/python/pytest-runner/pytest-runner.SlackBuild b/python/pytest-runner/pytest-runner.SlackBuild
index 3a0a0df1555a..e9a9a205dd6a 100644
--- a/python/pytest-runner/pytest-runner.SlackBuild
+++ b/python/pytest-runner/pytest-runner.SlackBuild
@@ -69,12 +69,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-
-if $(python3 -c 'import sys' 2>/dev/null); then
- rm -rf build
- python3 setup.py install --root=$PKG
-fi
+python2 setup.py install --root=$PKG
+rm -rf build
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true