aboutsummaryrefslogtreecommitdiff
path: root/python
diff options
context:
space:
mode:
authorfourtysixandtwo <fourtysixandtwo@sliderr.net>2023-04-10 08:17:12 -0600
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-04-15 07:15:35 +0700
commit074e47259d4858ab62f3e65bcc22d95ee4223856 (patch)
tree08a48c1e9441d236c5ae990e5f476c94c07ffc91 /python
parent81080408c52d601f0099717c649101e379a959d5 (diff)
python/python3-APScheduler: Updated for version 3.10.1.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-APScheduler/python3-APScheduler.SlackBuild11
-rw-r--r--python/python3-APScheduler/python3-APScheduler.info6
2 files changed, 7 insertions, 10 deletions
diff --git a/python/python3-APScheduler/python3-APScheduler.SlackBuild b/python/python3-APScheduler/python3-APScheduler.SlackBuild
index ccacefc662ac..a7f3291d760f 100644
--- a/python/python3-APScheduler/python3-APScheduler.SlackBuild
+++ b/python/python3-APScheduler/python3-APScheduler.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-APScheduler
-# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2022-23 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-APScheduler
SRCNAM=$(echo $PRGNAM | sed "s/python3-//")
-VERSION=${VERSION:-3.9.1.post1}
+VERSION=${VERSION:-3.10.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -76,9 +73,9 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
python3 setup.py install --root=$PKG
diff --git a/python/python3-APScheduler/python3-APScheduler.info b/python/python3-APScheduler/python3-APScheduler.info
index e321c3213867..9c413ea003d3 100644
--- a/python/python3-APScheduler/python3-APScheduler.info
+++ b/python/python3-APScheduler/python3-APScheduler.info
@@ -1,8 +1,8 @@
PRGNAM="python3-APScheduler"
-VERSION="3.9.1.post1"
+VERSION="3.10.1"
HOMEPAGE="https://pypi.python.org/pypi/APScheduler/"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/a/apscheduler/APScheduler-3.9.1.post1.tar.gz"
-MD5SUM="c08d806f83f46c088a2312580170535a"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/a/apscheduler/APScheduler-3.10.1.tar.gz"
+MD5SUM="ee88faf95c4bce3073758446dd03451f"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="tzlocal"