aboutsummaryrefslogtreecommitdiff
path: root/python
diff options
context:
space:
mode:
authorDave Woodfall <dave@slackbuilds.org>2021-05-21 21:32:17 +0100
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2021-06-02 01:02:26 +0700
commitda0778534ec6ccd06828318589557b4abdd72bde (patch)
tree4213c1900eaf0ba337b0e784da2a243ca79ca5ff /python
parentaaf1c4b7b81f48c7769657206af05c2014c3a25b (diff)
downloadslackbuilds-da0778534ec6ccd06828318589557b4abdd72bde.tar.xz
python/path.py: Convert python to python2.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/path.py/=1.15.0]0
-rw-r--r--python/path.py/path.py.SlackBuild8
2 files changed, 2 insertions, 6 deletions
diff --git a/python/path.py/=1.15.0] b/python/path.py/=1.15.0]
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/python/path.py/=1.15.0]
diff --git a/python/path.py/path.py.SlackBuild b/python/path.py/path.py.SlackBuild
index 9cf4f5d6d379..d80bba9e3bce 100644
--- a/python/path.py/path.py.SlackBuild
+++ b/python/path.py/path.py.SlackBuild
@@ -69,12 +69,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-
-# Python 3 support.
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true