aboutsummaryrefslogtreecommitdiff
path: root/python
diff options
context:
space:
mode:
authorB. Watson <urchlay@slackware.uk>2023-05-15 22:06:33 -0400
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-05-20 11:17:39 +0700
commit0d0e1a25fa6566a0493e8457bd16102602a20a00 (patch)
tree0b2d39203a6c2cd4541376a26a8483cf42a72d6e /python
parent348a500112bb0b304c3046637ed6c36ace1c357e (diff)
python/reedsolo: Align with template.
Signed-off-by: B. Watson <urchlay@slackware.uk> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/reedsolo/reedsolo.SlackBuild22
1 files changed, 7 insertions, 15 deletions
diff --git a/python/reedsolo/reedsolo.SlackBuild b/python/reedsolo/reedsolo.SlackBuild
index 76669f095987e..36ed54f1046fe 100644
--- a/python/reedsolo/reedsolo.SlackBuild
+++ b/python/reedsolo/reedsolo.SlackBuild
@@ -38,15 +38,12 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
fi
-TMP=${TMP:-/tmp}
+TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -67,18 +64,13 @@ find -L . \
rm -f creedsolo.c
-# Python 2.7 will be droped in the future.
-if $(python2 -c 'import sys' 2>/dev/null); then
- python2 setup.py install --root=$PKG
-else
- python setup.py install --root=$PKG
-fi
+# Python 2.7 will be dropped in the future.
+python2 setup.py install --root=$PKG
-# Replacement of python-2.x Python3.x check presence and build if found.
-if $(python3 -c 'import sys' 2>/dev/null); then
- rm -f creedsolo.c
- python3 setup.py install --root=$PKG
-fi
+rm -f creedsolo.c
+python3 setup.py install --root=$PKG
+
+strip $PKG/usr/lib*/python*/site-packages/*.so
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION