aboutsummaryrefslogtreecommitdiff
path: root/python
diff options
context:
space:
mode:
authorArn0 <yth@ythogtha.org>2023-07-04 14:18:19 +0200
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-07-06 11:23:35 +0700
commit8cc703cdbd4b3f643173099a5d7bb75d71a16178 (patch)
tree9128d4109ccb4011ca2ea232783dfa732256ac7e /python
parent73a1a41d1f6996504e286fefa5ef1fba49f7dfc5 (diff)
python/python2-ldap: Removed: obsolete, outdated, unmaintained, not working, or not needed anymore.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python2-ldap/README6
-rw-r--r--python/python2-ldap/python2-ldap.SlackBuild99
-rw-r--r--python/python2-ldap/python2-ldap.info10
-rw-r--r--python/python2-ldap/slack-desc19
4 files changed, 0 insertions, 134 deletions
diff --git a/python/python2-ldap/README b/python/python2-ldap/README
deleted file mode 100644
index 6f6f67f8908c7..0000000000000
--- a/python/python2-ldap/README
+++ /dev/null
@@ -1,6 +0,0 @@
-python-ldap provides an object-oriented API to access LDAP directory
-servers from Python programs. Mainly it wraps the OpenLDAP client libs
-for that purpose.
-
-Additionally, this package contains modules for other LDAP-related
-stuff (e.g. processing LDIF, LDAPURLs, LDAPv3 sub-schema, etc.).
diff --git a/python/python2-ldap/python2-ldap.SlackBuild b/python/python2-ldap/python2-ldap.SlackBuild
deleted file mode 100644
index 8ed6538982f61..0000000000000
--- a/python/python2-ldap/python2-ldap.SlackBuild
+++ /dev/null
@@ -1,99 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for python2-ldap
-
-# Copyright 2018-2022 Thibaut Notteboom, Paris, FRANCE
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=python2-ldap
-VERSION=${VERSION:-3.3.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-SRCNAM=python-ldap
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python2 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- CHANGES CONTRIBUTING.rst Doc/ LICENCE README TODO \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python2-ldap/python2-ldap.info b/python/python2-ldap/python2-ldap.info
deleted file mode 100644
index bacbfcf90f07e..0000000000000
--- a/python/python2-ldap/python2-ldap.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python2-ldap"
-VERSION="3.3.1"
-HOMEPAGE="https://www.python-ldap.org/"
-DOWNLOAD="https://github.com/python-ldap/python-ldap/archive/python-ldap-3.3.1/python-ldap-python-ldap-3.3.1.tar.gz"
-MD5SUM="f20b7b2aaf63d30839ebad32329c9164"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="coverage python2-pyasn1-modules"
-MAINTAINER="Thibaut Notteboom"
-EMAIL="thibaut.notteboom@gmail.com"
diff --git a/python/python2-ldap/slack-desc b/python/python2-ldap/slack-desc
deleted file mode 100644
index 85c4ea7df399f..0000000000000
--- a/python/python2-ldap/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python2-ldap: python2-ldap (LDAP client API for Python)
-python2-ldap:
-python2-ldap: python2-ldap provides an object-oriented API to access LDAP directory
-python2-ldap: servers from Python programs. Mainly it wraps the OpenLDAP client libs
-python2-ldap: for that purpose.
-python2-ldap:
-python2-ldap: Additionally, this package contains modules for other LDAP-related
-python2-ldap: stuff (e.g. processing LDIF, LDAPURLs, LDAPv3 sub-schema, etc.).
-python2-ldap:
-python2-ldap:
-python2-ldap: