aboutsummaryrefslogtreecommitdiff
path: root/python
diff options
context:
space:
mode:
authorJeremy Hansen <jebrhansen+github@gmail.com>2024-06-30 01:37:55 -0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-06-30 18:05:23 +0700
commit24455c214750427a93f6289a9b40451077f77748 (patch)
tree68e61f91f82cf6c36601da480de3c365166df234 /python
parent5b36fb847bbfe15a11b0a70172d469e3d848514b (diff)
python/python3-enzyme: Version bump to 0.5.2
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-enzyme/python3-enzyme.SlackBuild20
-rw-r--r--python/python3-enzyme/python3-enzyme.info8
2 files changed, 20 insertions, 8 deletions
diff --git a/python/python3-enzyme/python3-enzyme.SlackBuild b/python/python3-enzyme/python3-enzyme.SlackBuild
index a206304a463f7..beb8f297ac31a 100644
--- a/python/python3-enzyme/python3-enzyme.SlackBuild
+++ b/python/python3-enzyme/python3-enzyme.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-enzyme
-# Copyright 2023 Jeremy Hansen jebrhansen+SBo@gmail.com
+# Copyright 2023-2024 Jeremy Hansen jebrhansen+SBo@gmail.com
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-enzyme
-VERSION=${VERSION:-0.4.1}
+VERSION=${VERSION:-0.5.2}
SRCNAM=${SRCNAM:-enzyme}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -62,14 +62,26 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+# Add unused section to avoid ERROR message from setuptools_scm
+# Make it an if statement just in case upstream decides to update
+# it and I don't notice.
+if ! grep -qF "[tool.setuptools_scm]" pyproject.toml; then
+ echo "[tool.setuptools_scm]" >> pyproject.toml
+fi
+export SETUPTOOLS_SCM_PRETEND_VERSION=$VERSION
+
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
+
+python3 -m build --wheel --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- HISTORY.rst LICENSE README.rst \
+ LICENSE README.md \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/python/python3-enzyme/python3-enzyme.info b/python/python3-enzyme/python3-enzyme.info
index 95dfa72eba92e..5f638c12962bf 100644
--- a/python/python3-enzyme/python3-enzyme.info
+++ b/python/python3-enzyme/python3-enzyme.info
@@ -1,10 +1,10 @@
PRGNAM="python3-enzyme"
-VERSION="0.4.1"
+VERSION="0.5.2"
HOMEPAGE="https://github.com/Diaoul/enzyme/"
-DOWNLOAD="https://github.com/Diaoul/enzyme/archive/refs/tags/0.4.1/enzyme-0.4.1.tar.gz"
-MD5SUM="eb2c076cbd784007b4a3f880fe1590f1"
+DOWNLOAD="https://github.com/Diaoul/enzyme/archive/refs/tags/0.5.2/enzyme-0.5.2.tar.gz"
+MD5SUM="11174fa4fa06a14fc66b8d580d6fe694"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="python3-setuptools-opt"
MAINTAINER="Jeremy Hansen"
EMAIL="jebrhansen+SBo@gmail.com"