aboutsummaryrefslogtreecommitdiff
path: root/python
diff options
context:
space:
mode:
authorVijay Marcel <vijaymarcel@outlook.com>2024-10-08 11:04:32 +0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-10-11 11:48:41 +0700
commit58fd9937ac234cc9e8d5cf51cb62d5d46dbce1b3 (patch)
tree96f8a4f937c07f34ec50b8c4828caef20abeeee8 /python
parent96e35dd1e275f883f0b51444471e401e55bd351c (diff)
python/python3-reportlab: Updated for version 4.2.5.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-reportlab/README6
-rw-r--r--python/python3-reportlab/python3-reportlab.SlackBuild12
-rw-r--r--python/python3-reportlab/python3-reportlab.info6
3 files changed, 15 insertions, 9 deletions
diff --git a/python/python3-reportlab/README b/python/python3-reportlab/README
index d382fe51ea45..5f2c0a3a64b1 100644
--- a/python/python3-reportlab/README
+++ b/python/python3-reportlab/README
@@ -18,3 +18,9 @@ It has the following features:
- strong community support
- platform-independent
- includes PythonPoint - PDF Presentation Tool
+
+For document generation,Reportlab has a circular dependency on itself
+So you have to install reportlab first and then extract the source
+to some $DIR and then cd to $DIR/reportlab-$VER/docs and then
+run python3 genAll.py it will generate a pdf file, which you can copy it
+to some other convenient location.
diff --git a/python/python3-reportlab/python3-reportlab.SlackBuild b/python/python3-reportlab/python3-reportlab.SlackBuild
index 34ddf2199a80..d5a3e6865fef 100644
--- a/python/python3-reportlab/python3-reportlab.SlackBuild
+++ b/python/python3-reportlab/python3-reportlab.SlackBuild
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-reportlab
-VERSION=${VERSION:-4.2.2}
+VERSION=${VERSION:-4.2.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -65,15 +65,15 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --prefix=/usr --root=$PKG --optimize=1
+CFLAGS="$SLKCFLAGS" CXXFLAGS="$SLKCFLAGS" python3 setup.py --no-download-t1-files --verbose install --prefix=/usr --root=$PKG --optimize=1
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+ | cut -f 1 -d : | xargs strip --strip-unneeded --reove-section=.comment --remove-section=.note 2> /dev/null || true
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a docs CHANGES.md LICENSE README.txt VERSION.txt $PKG/usr/doc/$PRGNAM-$VERSION
+mkdir -pv $PKG/usr/doc/$PRGNAM-$VERSION
+cp -av docs CHANGES.md LICENSE README.txt $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 0644 {} \+
+find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod -v 0644 {} \+
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
diff --git a/python/python3-reportlab/python3-reportlab.info b/python/python3-reportlab/python3-reportlab.info
index 0fabb219d7b1..e9b961789595 100644
--- a/python/python3-reportlab/python3-reportlab.info
+++ b/python/python3-reportlab/python3-reportlab.info
@@ -1,8 +1,8 @@
PRGNAM="python3-reportlab"
-VERSION="4.2.2"
+VERSION="4.2.5"
HOMEPAGE="https://reportlab.com"
-DOWNLOAD="https://pypi.org/packages/source/r/reportlab/reportlab-4.2.2.tar.gz"
-MD5SUM="5198e2ec141b3ad8ab0ddc14065f83e0"
+DOWNLOAD="https://pypi.org/packages/source/r/reportlab/reportlab-4.2.5.tar.gz"
+MD5SUM="4334edd0b173593476efd589d4f59258"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""