aboutsummaryrefslogtreecommitdiff
path: root/python
diff options
context:
space:
mode:
authorJeremy Hansen <jebrhansen+github@gmail.com>2024-06-24 17:08:37 -0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-06-26 08:05:47 +0700
commita592bf10881995c89e0791e1724fe8a6540d5b74 (patch)
tree7e0dc353d2e4aca62b90656ccc5f39c9244401de /python
parentf9cc83b464ee9177e42870837a25e8e52488e2e2 (diff)
python/python3-pyproject-api: Version bump to 1.7.1
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-pyproject-api/python3-pyproject-api.SlackBuild23
-rw-r--r--python/python3-pyproject-api/python3-pyproject-api.info6
2 files changed, 10 insertions, 19 deletions
diff --git a/python/python3-pyproject-api/python3-pyproject-api.SlackBuild b/python/python3-pyproject-api/python3-pyproject-api.SlackBuild
index 5f3a30df6b236..b644ab0940b4e 100644
--- a/python/python3-pyproject-api/python3-pyproject-api.SlackBuild
+++ b/python/python3-pyproject-api/python3-pyproject-api.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-pyproject-api
-# Copyright 2023 Jeremy Hansen jebrhansen+SBo@gmail.com
+# Copyright 2023-2024 Jeremy Hansen jebrhansen+SBo@gmail.com
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-pyproject-api
-VERSION=${VERSION:-1.6.1}
+VERSION=${VERSION:-1.7.1}
SRCNAM=${SRCNAM:-pyproject-api}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -47,20 +47,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -78,6 +64,11 @@ find -L . \
export SETUPTOOLS_SCM_PRETEND_VERSION=$VERSION
+# Revert unnecessary dependency version requirements
+sed -i 's|1\.24\.2|1\.18|' pyproject.toml # hatchling
+sed -i 's|2\.0\.1|1\.2\.2|' pyproject.toml # tomli
+sed -i 's|24\.1|21\.0|' pyproject.toml # packaging
+
python3 -m build --wheel --no-isolation
python3 -m installer --destdir=$PKG dist/*.whl
diff --git a/python/python3-pyproject-api/python3-pyproject-api.info b/python/python3-pyproject-api/python3-pyproject-api.info
index c227b18342942..684526d8f0e86 100644
--- a/python/python3-pyproject-api/python3-pyproject-api.info
+++ b/python/python3-pyproject-api/python3-pyproject-api.info
@@ -1,8 +1,8 @@
PRGNAM="python3-pyproject-api"
-VERSION="1.6.1"
+VERSION="1.7.1"
HOMEPAGE="https://pyproject-api.readthedocs.io/en/latest/"
-DOWNLOAD="https://github.com/tox-dev/pyproject-api/archive/refs/tags/1.6.1/pyproject-api-1.6.1.tar.gz"
-MD5SUM="640a1bce926d72ae5af769541c2a89a5"
+DOWNLOAD="https://github.com/tox-dev/pyproject-api/archive/refs/tags/1.7.1/pyproject-api-1.7.1.tar.gz"
+MD5SUM="f44070444272166375656ee6eae2f35c"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="python3-hatch_vcs"