aboutsummaryrefslogtreecommitdiff
path: root/python
diff options
context:
space:
mode:
authorfourtysixandtwo <fourtysixandtwo@sliderr.net>2024-09-10 05:10:43 -0600
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-09-14 23:37:07 +0700
commitbc742a3c17a41284a544a7506db9ef4f245957dd (patch)
tree2abc3920394b602aa4cf3dbebe214822d809a37d /python
parent1e1869fee6ec3d4860926d34bcdefe633bc72c6c (diff)
python/python3-pyproject-api: Fix for new hatchling.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python')
-rw-r--r--python/python3-pyproject-api/python3-pyproject-api.SlackBuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/python/python3-pyproject-api/python3-pyproject-api.SlackBuild b/python/python3-pyproject-api/python3-pyproject-api.SlackBuild
index b644ab0940b4..715c2314fc08 100644
--- a/python/python3-pyproject-api/python3-pyproject-api.SlackBuild
+++ b/python/python3-pyproject-api/python3-pyproject-api.SlackBuild
@@ -62,12 +62,12 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages
export SETUPTOOLS_SCM_PRETEND_VERSION=$VERSION
# Revert unnecessary dependency version requirements
-sed -i 's|1\.24\.2|1\.18|' pyproject.toml # hatchling
sed -i 's|2\.0\.1|1\.2\.2|' pyproject.toml # tomli
-sed -i 's|24\.1|21\.0|' pyproject.toml # packaging
python3 -m build --wheel --no-isolation
python3 -m installer --destdir=$PKG dist/*.whl