aboutsummaryrefslogtreecommitdiff
path: root/python/yara-python
diff options
context:
space:
mode:
authorBarry J. Grundy <bgrundy@linuxleo.com>2021-11-11 08:58:33 +0100
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2021-11-12 00:39:41 +0700
commit1a54f79050ec2793d0da5925cfa3301556bbdbf0 (patch)
tree3101db3f3c3f49f625e343710163e2a6aad09538 /python/yara-python
parentb45df7c09b13330e3e2a8ed51fe595ada87e27f7 (diff)
python/yara-python: Updated for version 4.1.2.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/yara-python')
-rw-r--r--python/yara-python/yara-python.SlackBuild10
-rw-r--r--python/yara-python/yara-python.info6
2 files changed, 8 insertions, 8 deletions
diff --git a/python/yara-python/yara-python.SlackBuild b/python/yara-python/yara-python.SlackBuild
index 302ef900f04cc..e78977782ea61 100644
--- a/python/yara-python/yara-python.SlackBuild
+++ b/python/yara-python/yara-python.SlackBuild
@@ -1,7 +1,7 @@
#!/bin/bash
# Slackware build script for yara-python
-# Copyright 2017 Barry Grundy <bgrundy[at]linuxleo.com>
+# Copyright 2017-2021 Barry Grundy <bgrundy[at]linuxleo.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -21,12 +21,12 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
#
-# New build - v3.5.0, January 2017, Barry J. Grundy.
+# updated - v4.1.2, August 2021, Barry J. Grundy.
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=yara-python
-VERSION=${VERSION:-3.5.0}
+VERSION=${VERSION:-4.1.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -82,8 +82,8 @@ find -L . \
export CC="gcc $SLKCFLAGS $(pkg-config --cflags talloc)"
-python setup.py build --dynamic-linking
-python setup.py install --root=$PKG
+python2 setup.py build --dynamic-linking
+python2 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/yara-python/yara-python.info b/python/yara-python/yara-python.info
index 5ac8fd06f732d..856fe459d0c95 100644
--- a/python/yara-python/yara-python.info
+++ b/python/yara-python/yara-python.info
@@ -1,8 +1,8 @@
PRGNAM="yara-python"
-VERSION="3.5.0"
+VERSION="4.1.2"
HOMEPAGE="https://github.com/VirusTotal/yara-python"
-DOWNLOAD="https://github.com/VirusTotal/yara-python/archive/v3.5.0/yara-python-3.5.0.tar.gz"
-MD5SUM="a6dc00c73deabf1dcf3581c5573280eb"
+DOWNLOAD="https://github.com/VirusTotal/yara-python/archive/v4.1.2/yara-python-4.1.2.tar.gz"
+MD5SUM="12e4e862cb67da2e769581a53557efa5"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="yara"