aboutsummaryrefslogtreecommitdiff
path: root/python/workbook
diff options
context:
space:
mode:
authorB. Watson <urchlay@slackware.uk>2023-05-15 22:21:37 -0400
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-05-20 11:17:40 +0700
commit8b0d57fb71a5d0f050d2fb26727d764124b2d33d (patch)
tree3c977a5c790623498e33b3e4f8459dc5515bc5a6 /python/workbook
parent45cf8f35443bcfc3fa720e56db6ab769c2bcbe3f (diff)
python/workbook: Align with template.
Signed-off-by: B. Watson <urchlay@slackware.uk> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/workbook')
-rw-r--r--python/workbook/workbook.SlackBuild22
1 files changed, 7 insertions, 15 deletions
diff --git a/python/workbook/workbook.SlackBuild b/python/workbook/workbook.SlackBuild
index 23a2ae143d0b5..f1928a2d34673 100644
--- a/python/workbook/workbook.SlackBuild
+++ b/python/workbook/workbook.SlackBuild
@@ -40,15 +40,12 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
fi
-TMP=${TMP:-/tmp}
+TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -63,21 +60,16 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
- # Python 2.7 will be droped in the future.
-if $(python2 -c 'import sys' 2>/dev/null); then
- python2 setup.py install --root=$PKG
-fi
-# Replacement of python-2.x Python3.x check presence and build if found.
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+# Python 2.7 will be dropped in the future.
+python2 setup.py install --root=$PKG
+
+python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-#cp -a LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install