aboutsummaryrefslogtreecommitdiff
path: root/python/terminado/terminado.SlackBuild
diff options
context:
space:
mode:
authorIsaac Yu <isaacyu1@isaacyu1.com>2022-05-27 23:03:36 -0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-06-04 10:37:20 +0700
commit03f0407421931694a713f51b16813202ec2d44fb (patch)
tree7d3330e5d4006baa8fb6d8ee2da9442cfd0d6db6 /python/terminado/terminado.SlackBuild
parent62b9e2ac1fbe53ac35e3770d6e546c23ec72c038 (diff)
python/terminado: Update for 0.15.0
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/terminado/terminado.SlackBuild')
-rw-r--r--python/terminado/terminado.SlackBuild18
1 files changed, 16 insertions, 2 deletions
diff --git a/python/terminado/terminado.SlackBuild b/python/terminado/terminado.SlackBuild
index 1316ea5b80b15..a9b355606d1ee 100644
--- a/python/terminado/terminado.SlackBuild
+++ b/python/terminado/terminado.SlackBuild
@@ -26,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=terminado
-VERSION=${VERSION:-0.13.3}
+VERSION=${VERSION:-0.15.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -80,7 +80,21 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+# Use this setup.py shim:
+cat << EOF > setup.py
+from setuptools import setup, find_packages
+setup(name='${PRGNAM}',
+ version='${VERSION}',
+ packages=find_packages(),
+ package_data={'': ['*'], 'terminado': ['_static/*']},
+ install_requires=["ptyprocess;os_name!='nt'", "pywinpty>=1.1.0;os_name=='nt'", "tornado>=6.1.0"],
+ extras_require={'test': ['pytest']},
+)
+EOF
+
+# With the shim, it's a good idea to use "unshare -n" to prevent downloading
+# anything extra:
+unshare -n python3 setup.py install --root=$PKG || exit 1
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true