aboutsummaryrefslogtreecommitdiff
path: root/python/sge-pygame/sge-pygame.SlackBuild
diff options
context:
space:
mode:
authorDimitris Zlatanidis <d.zlatanidis@gmail.com>2022-03-07 13:05:32 +0200
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-03-08 09:46:13 +0700
commitf5a4f3d66d30ec936968529200037939cc1249fa (patch)
treeaa304de5ea65c19db858db8c06436f3ce6869888 /python/sge-pygame/sge-pygame.SlackBuild
parentc250a757dfd312fe321a1d224c029dad9d8e4256 (diff)
python/sge-pygame: Updated for version 2.0.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com> Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/sge-pygame/sge-pygame.SlackBuild')
-rw-r--r--python/sge-pygame/sge-pygame.SlackBuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/python/sge-pygame/sge-pygame.SlackBuild b/python/sge-pygame/sge-pygame.SlackBuild
index 260541e54dd50..e0459584baf19 100644
--- a/python/sge-pygame/sge-pygame.SlackBuild
+++ b/python/sge-pygame/sge-pygame.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for sge-pygame
-# Copyright 2014-2017 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2014-2022 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=sge-pygame
-VERSION=${VERSION:-1.5}
+VERSION=${VERSION:-2.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -46,6 +46,8 @@ if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
exit 0
fi
+SRCNAM=sge
+
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -69,9 +71,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -79,7 +81,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true