aboutsummaryrefslogtreecommitdiff
path: root/python/python3-twisted/python3-twisted.SlackBuild
diff options
context:
space:
mode:
authorArn0 <yth@ythogtha.org>2023-09-09 16:29:11 +0200
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-09-17 00:10:27 +0700
commit8d6f7dcf33d317e434e7760a541c433b69311cda (patch)
treea811ecaf270bd3d6973a716c562686b3a43c2a42 /python/python3-twisted/python3-twisted.SlackBuild
parent69886025f6690014d049778375009febe30b820c (diff)
python/python3-twisted: Updated for version 23.8.0.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-twisted/python3-twisted.SlackBuild')
-rw-r--r--python/python3-twisted/python3-twisted.SlackBuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/python/python3-twisted/python3-twisted.SlackBuild b/python/python3-twisted/python3-twisted.SlackBuild
index c10b106715302..02d4eb4ac2c93 100644
--- a/python/python3-twisted/python3-twisted.SlackBuild
+++ b/python/python3-twisted/python3-twisted.SlackBuild
@@ -28,8 +28,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-twisted
-SRCNAM=Twisted
-VERSION=${VERSION:-22.10.0}
+SRCNAM=${PRGNAM#python3-*}
+VERSION=${VERSION:-23.8.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -83,7 +83,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true