aboutsummaryrefslogtreecommitdiff
path: root/python/python3-putio.py
diff options
context:
space:
mode:
authorJeremy Hansen <jebrhansen+github@gmail.com>2024-03-04 21:22:44 -0800
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-03-05 12:35:05 +0700
commitd698d0df2a844b461558b7d7d4c019627eb4fa84 (patch)
treedb4c8dfe7501a032feb6a1f39d492040fe761d48 /python/python3-putio.py
parent8c6703c91920ca1689ca548afc81a5351a6cda0d (diff)
python/python3-putio.py: Fix versioning issue
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-putio.py')
-rw-r--r--python/python3-putio.py/python3-putio.py.SlackBuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/python/python3-putio.py/python3-putio.py.SlackBuild b/python/python3-putio.py/python3-putio.py.SlackBuild
index db7c597e4287e..88e4b5676732a 100644
--- a/python/python3-putio.py/python3-putio.py.SlackBuild
+++ b/python/python3-putio.py/python3-putio.py.SlackBuild
@@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-putio.py
SRCNAM=putio.py
VERSION=${VERSION:-8.7.0}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -76,6 +76,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Fix building from source
+sed -i "s/'0'/\'$VERSION\'/" setup.py
+
python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \