aboutsummaryrefslogtreecommitdiff
path: root/python/python3-nxt-python
diff options
context:
space:
mode:
authorklaatu <klaatu@member.fsf.org>2022-03-09 20:09:55 +1300
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-03-09 17:16:40 +0700
commitfaf41159f3d91f7720b86b0d2d22d1e70182523f (patch)
treea55d9c353a0c0cb710d74275b381a36fd54f5dde /python/python3-nxt-python
parent89c42120c15246c81de1f5a474c6312427887d8f (diff)
python/nxt-python3: Updated for version 3.0.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-nxt-python')
-rw-r--r--python/python3-nxt-python/70-lego.rules1
-rw-r--r--python/python3-nxt-python/README37
-rw-r--r--python/python3-nxt-python/python3-nxt-python.SlackBuild86
-rw-r--r--python/python3-nxt-python/python3-nxt-python.info10
-rw-r--r--python/python3-nxt-python/slack-desc19
5 files changed, 153 insertions, 0 deletions
diff --git a/python/python3-nxt-python/70-lego.rules b/python/python3-nxt-python/70-lego.rules
new file mode 100644
index 000000000000..36499b5ddf99
--- /dev/null
+++ b/python/python3-nxt-python/70-lego.rules
@@ -0,0 +1 @@
+SUBSYSTEM=="usb", ATTRS{idVendor}=="0694", GROUP="lego", MODE="0660" \ No newline at end of file
diff --git a/python/python3-nxt-python/README b/python/python3-nxt-python/README
new file mode 100644
index 000000000000..45dd72cbd431
--- /dev/null
+++ b/python/python3-nxt-python/README
@@ -0,0 +1,37 @@
+nxt-python (python module to control Lego NXT)
+
+nxt-python is a python 2.x driver/interface for the Lego Mindstorms
+NXT robot.
+
+Setup
+------
+
+In order to use nxt-python with an NXT kit, you should add a 'lego'
+group to your system, and add yourself to that group:
+
+ # groupadd lego
+ # usermod -a -G lego YourUserName
+
+You will also want to set up a udev rule to identify NXT hardware and
+grant the 'lego' group permission to use it.
+
+A sample rule is included for you in /usr/share/python3-nxt-python,
+but you should verify the vendor code of the NXT unit.
+
+To verify a vendor code, connect the NXT hardware to your computer
+and then run:
+
+ # lsusb
+
+Look at the ID for the Lego device; it will probably be 0694, but if not,
+then change the value in the sample udev rule to match.
+
+Save the sample udev rule (70-lego.rules) to /etc/udev/rules.d/
+
+Log out and log back in, and you should now have full control, via Python,
+over your NXT hardware.
+
+Requires at least one of these
+-------------------------------
+python3-pyusb (for USB communication)
+python3-pybluez (for bluetooth communication)
diff --git a/python/python3-nxt-python/python3-nxt-python.SlackBuild b/python/python3-nxt-python/python3-nxt-python.SlackBuild
new file mode 100644
index 000000000000..0c88046f13d3
--- /dev/null
+++ b/python/python3-nxt-python/python3-nxt-python.SlackBuild
@@ -0,0 +1,86 @@
+#!/bin/bash
+
+# Slackware build script for nxt-python
+# Copyright 2014-22 klaatu @member.fsf.org
+
+# GNU All-Permissive License
+# Copying and distribution of this file, with or without modification,
+# are permitted in any medium without royalty provided the copyright
+# notice and this notice are preserved. This file is offered as-is,
+# without any warranty.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=python3-nxt-python
+SRCNAM=nxt-python
+VERSION=${VERSION:-3.0.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+mkdir $PRGNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz --strip-components=1 \
+ -C $PRGNAM-$VERSION
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/share/$PRGNAM-$VERSION
+cp -ar examples $PKG/usr/share/$PRGNAM-$VERSION
+cat $CWD/70-lego.rules > $PKG/usr/share/$PRGNAM-$VERSION/70-lego.rules
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.md LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/python3-nxt-python/python3-nxt-python.info b/python/python3-nxt-python/python3-nxt-python.info
new file mode 100644
index 000000000000..a2a7c8811163
--- /dev/null
+++ b/python/python3-nxt-python/python3-nxt-python.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-nxt-python"
+VERSION="3.0.0"
+HOMEPAGE="https://github.com/schodet/nxt-python"
+DOWNLOAD="https://github.com/schodet/nxt-python/archive/3.0.0/nxt-python-3.0.0.tar.gz"
+MD5SUM="6bafd443e4c1bf053becc9e23dc53036"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-pyusb python3-pybluez"
+MAINTAINER="klaatu"
+EMAIL="klaatu@member.fsf.org"
diff --git a/python/python3-nxt-python/slack-desc b/python/python3-nxt-python/slack-desc
new file mode 100644
index 000000000000..3206703a6d3a
--- /dev/null
+++ b/python/python3-nxt-python/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-nxt-python: python3-nxt-python (Python3 module to control Lego NXT)
+python3-nxt-python:
+python3-nxt-python: nxt-python is a Python driver and interface for the
+python3-nxt-python: Lego Mindstorms NXT robot.
+python3-nxt-python:
+python3-nxt-python: https://github.com/schodet/nxt-python
+python3-nxt-python:
+python3-nxt-python:
+python3-nxt-python:
+python3-nxt-python:
+python3-nxt-python: