aboutsummaryrefslogtreecommitdiff
path: root/python/python3-lsp-server
diff options
context:
space:
mode:
authorisaackwy <isaacyu@protonmail.com>2023-12-30 12:37:31 -0800
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-12-31 09:14:03 +0700
commit837f27a68cce7a4b2098e84181f70e51aa79b1f3 (patch)
tree566d6cb0a2add108933643debf354d6dc213ef9d /python/python3-lsp-server
parent5147fe7ad88a426c89617e13d242f2fe9a95bb24 (diff)
python/python3-lsp-server: Update for 1.6.0
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-lsp-server')
-rw-r--r--python/python3-lsp-server/README4
-rw-r--r--python/python3-lsp-server/python3-lsp-server.SlackBuild23
-rw-r--r--python/python3-lsp-server/python3-lsp-server.info8
3 files changed, 20 insertions, 15 deletions
diff --git a/python/python3-lsp-server/README b/python/python3-lsp-server/README
index 143490a6e88f1..265c680e8edaf 100644
--- a/python/python3-lsp-server/README
+++ b/python/python3-lsp-server/README
@@ -1,5 +1,5 @@
Python LSP Server is a Python 3.7+ implementation of the Language
Server Protocol.
-python3-lsp-server 1.4.1 is the last available version for Slackware
-15.0. Newer versions require a newer python-setuptools.
+python3-lsp-server 1.6.0 is the last available version for Slackware
+15.0. Newer versions require a newer python3-rope.
diff --git a/python/python3-lsp-server/python3-lsp-server.SlackBuild b/python/python3-lsp-server/python3-lsp-server.SlackBuild
index 7344275df98b1..d0cc6752a3f2d 100644
--- a/python/python3-lsp-server/python3-lsp-server.SlackBuild
+++ b/python/python3-lsp-server/python3-lsp-server.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-lsp-server
-# Copyright 2023 Isaac Yu <isaacyu@protonmail.com>
+# Copyright 2023-2024 Isaac Yu <isaacyu@protonmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-lsp-server
-VERSION=${VERSION:-1.4.1}
+VERSION=${VERSION:-1.6.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -79,13 +79,18 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Workarounds for spyder
-sed -i "s|autopep8>=1.6.0,<1.7.0|autopep8>=1.6.0|" -i setup.cfg
-sed -i "s|flake8>=4.0.0,<4.1.0|flake8>=4.0.0|" -i setup.cfg
-sed -i "s|mccabe>=0.6.0,<0.7.0|mccabe>=0.6.0|" -i setup.cfg
-sed -i "s|pycodestyle>=2.8.0,<2.9.0|pycodestyle>=2.8.0|" -i setup.cfg
-sed -i "s|pyflakes>=2.4.0,<2.5.0|pyflakes>=2.4.0|" -i setup.cfg
-
-python3 setup.py install --root=$PKG
+sed -i "s|autopep8>=1.6.0,<1.7.0|autopep8>=1.6.0|" -i pyproject.toml
+sed -i "s|flake8>=5.0.0,<5.1.0|flake8>=5.1.0|" -i pyproject.toml
+sed -i "s|jedi>=0.17.2,<0.19.0|jedi>=0.17.2|" -i pyproject.toml
+sed -i "s|pycodestyle>=2.9.0,<2.10.0|pycodestyle>=2.9.0|" -i pyproject.toml
+sed -i "s|pyflakes>=2.5.0,<2.6.0|pyflakes>=2.5.0|" -i pyproject.toml
+sed -i "s|pylint>=2.5.0,<3|pylint>=2.5.0|" -i pyproject.toml
+
+# Use newer, non-stock setuptools due to package requirements
+export PYTHONPATH=/opt/python3.9/site-packages/
+
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/python3-lsp-server/python3-lsp-server.info b/python/python3-lsp-server/python3-lsp-server.info
index dfb079a1e175a..26de0e2f9ad64 100644
--- a/python/python3-lsp-server/python3-lsp-server.info
+++ b/python/python3-lsp-server/python3-lsp-server.info
@@ -1,10 +1,10 @@
PRGNAM="python3-lsp-server"
-VERSION="1.4.1"
+VERSION="1.6.0"
HOMEPAGE="https://github.com/python-lsp/python-lsp-server"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/p/python-lsp-server/python-lsp-server-1.4.1.tar.gz"
-MD5SUM="2c965860206e18fc192bbe6bd908edd9"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/p/python-lsp-server/python-lsp-server-1.6.0.tar.gz"
+MD5SUM="921920b6692d0f00832f63f3edc53c7e"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python3-jedi python3-pluggy python3-lsp-jsonrpc"
+REQUIRES="python3-docstring-to-markdown python3-jedi python3-lsp-jsonrpc python3-pluggy python3-setuptools-opt"
MAINTAINER="Isaac Yu"
EMAIL="isaacyu@protonmail.com"