aboutsummaryrefslogtreecommitdiff
path: root/python/python3-loguru/python3-loguru.SlackBuild
diff options
context:
space:
mode:
authorfourtysixandtwo <fourtysixandtwo@sliderr.net>2023-05-14 00:15:33 -0600
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-05-20 11:17:20 +0700
commit1539812fb9475b5d446f87ff29367d9461057b8d (patch)
tree68ef7d1dcbd0342967540b11894133f565ef8ffd /python/python3-loguru/python3-loguru.SlackBuild
parenta848c1fd072fd10d6a528af73cd7a2c9ad3a14e3 (diff)
python/python3-loguru: Updated for version 0.7.0.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-loguru/python3-loguru.SlackBuild')
-rw-r--r--python/python3-loguru/python3-loguru.SlackBuild13
1 files changed, 5 insertions, 8 deletions
diff --git a/python/python3-loguru/python3-loguru.SlackBuild b/python/python3-loguru/python3-loguru.SlackBuild
index 22eac8d80d8e..726a711a5064 100644
--- a/python/python3-loguru/python3-loguru.SlackBuild
+++ b/python/python3-loguru/python3-loguru.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-loguru
-# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2022-23 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,8 +25,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-loguru
-SRCNAM=$(echo $PRGNAM | sed "s/python3-//")
-VERSION=${VERSION:-0.6.0}
+SRCNAM=${PRGNAM#python3-*}
+VERSION=${VERSION:-0.7.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -76,9 +73,9 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
python3 setup.py install --root=$PKG