aboutsummaryrefslogtreecommitdiff
path: root/python/python3-kodipydent
diff options
context:
space:
mode:
authorJeremy Hansen <jebrhansen+github@gmail.com>2024-01-16 17:13:17 -0800
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-01-17 08:19:39 +0700
commit4d83bf102077f5ddb47f6af0b7b85b757607403e (patch)
tree50e0bd93c7f3c48d27cd9141d56c5fa15f63cced /python/python3-kodipydent
parentfe997dc4b30a64841a89ad701dc616174416dc45 (diff)
python/python3-kodipydent: Fix pip check warning
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-kodipydent')
-rw-r--r--python/python3-kodipydent/python3-kodipydent.SlackBuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/python/python3-kodipydent/python3-kodipydent.SlackBuild b/python/python3-kodipydent/python3-kodipydent.SlackBuild
index a1ed26e922120..38aa1c76c69d2 100644
--- a/python/python3-kodipydent/python3-kodipydent.SlackBuild
+++ b/python/python3-kodipydent/python3-kodipydent.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-kodipydent
-# Copyright 2023 Jeremy Hansen jebrhansen+SBo@gmail.com
+# Copyright 2023-2024 Jeremy Hansen jebrhansen+SBo@gmail.com
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-kodipydent
VERSION=${VERSION:-0.3.1}
SRCNAM=${SRCNAM:-kodipydent}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -76,6 +76,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Fix pip check warning
+# Update dependency name to newer alternate and remove version requirement
+sed -i 's/beekeeper.*/beekeeper-alt/' requirements.txt
+
python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \