aboutsummaryrefslogtreecommitdiff
path: root/python/python3-build/python3-build.SlackBuild
diff options
context:
space:
mode:
authorfourtysixandtwo <fourtysixandtwo@sliderr.net>2023-05-07 16:29:34 -0600
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-05-13 19:27:19 +0700
commitd698cfcc4b6379057415414fddd68a2fbd3b7d6b (patch)
tree43a5f8658e1e8e95e6145796656bf84f9bab55de /python/python3-build/python3-build.SlackBuild
parent730d0c666e03e580472897a23db3d86e8f5cd2bc (diff)
python/python3-build: Updated for version 0.10.0, new maintainer.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-build/python3-build.SlackBuild')
-rw-r--r--python/python3-build/python3-build.SlackBuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/python/python3-build/python3-build.SlackBuild b/python/python3-build/python3-build.SlackBuild
index afee47271f13b..7b0c46dffca8a 100644
--- a/python/python3-build/python3-build.SlackBuild
+++ b/python/python3-build/python3-build.SlackBuild
@@ -2,6 +2,7 @@
# Slackware build script for python3-build
+# Copyright 2023 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# Copyright 2022 toolonely <lonely_@tutanota.com>
# All rights reserved.
#
@@ -22,16 +23,18 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20230507 46and2: New maintainer, updated version and deps.
+# -build process changed
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-build
-VERSION=${VERSION:-0.7.0}
+SRCNAM=${PRGNAM#python3-*}
+VERSION=${VERSION:-0.10.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
-SRCNAM=build
-
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i586 ;;
@@ -74,11 +77,12 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-python3 setup.py install --root=$PKG
+python3 -m flit_core.wheel
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true