aboutsummaryrefslogtreecommitdiff
path: root/python/python3-Flask-WTF
diff options
context:
space:
mode:
authorfourtysixandtwo <fourtysixandtwo@sliderr.net>2023-01-22 12:17:17 -0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-01-28 08:22:49 +0700
commitd6a4df0f3131154235f02b287a496782ace50b21 (patch)
treecb8ae47262181405a61eb1431cdc7a1e15e3062a /python/python3-Flask-WTF
parent87ad1718697ee44e6477c29fda5c78130b72ace5 (diff)
python/python3-Flask-WTF: Updated for version 1.1.1.
Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python3-Flask-WTF')
-rw-r--r--python/python3-Flask-WTF/python3-Flask-WTF.SlackBuild11
-rw-r--r--python/python3-Flask-WTF/python3-Flask-WTF.info6
2 files changed, 7 insertions, 10 deletions
diff --git a/python/python3-Flask-WTF/python3-Flask-WTF.SlackBuild b/python/python3-Flask-WTF/python3-Flask-WTF.SlackBuild
index 3f51a77fbf1c..4060ea025cec 100644
--- a/python/python3-Flask-WTF/python3-Flask-WTF.SlackBuild
+++ b/python/python3-Flask-WTF/python3-Flask-WTF.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python3-Flask-WTF
-# Copyright 2022 fourtysixandtwo <fourtysixandtwo@sliderr.net>
+# Copyright 2022-23 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python3-Flask-WTF
SRCNAM=$(echo $PRGNAM | sed "s/python3-//")
-VERSION=${VERSION:-1.0.1}
+VERSION=${VERSION:-1.1.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -76,9 +73,9 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
python3 setup.py install --root=$PKG
diff --git a/python/python3-Flask-WTF/python3-Flask-WTF.info b/python/python3-Flask-WTF/python3-Flask-WTF.info
index c8942848e095..b021783941fa 100644
--- a/python/python3-Flask-WTF/python3-Flask-WTF.info
+++ b/python/python3-Flask-WTF/python3-Flask-WTF.info
@@ -1,8 +1,8 @@
PRGNAM="python3-Flask-WTF"
-VERSION="1.0.1"
+VERSION="1.1.1"
HOMEPAGE="https://github.com/lepture/flask-wtf"
-DOWNLOAD="https://files.pythonhosted.org/packages/source/f/flask-wtf/Flask-WTF-1.0.1.tar.gz"
-MD5SUM="d86dbc0befe30fd577a623a51689b900"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/f/flask-wtf/Flask-WTF-1.1.1.tar.gz"
+MD5SUM="007c1ff973c63096dec0fa805412d8ad"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="Flask python3-WTForms"