aboutsummaryrefslogtreecommitdiff
path: root/python/python2-klein
diff options
context:
space:
mode:
authorDave Woodfall <dave@slackbuilds.org>2021-05-14 21:34:38 +0100
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2021-05-19 18:40:01 +0700
commit22a820478e9338a29ffe8f0d59b58f93a377a41b (patch)
tree232660e6529452724c0c6c95996deb2aae1aac86 /python/python2-klein
parentb13eb3db5d307b714e52b6e289e9507262b96317 (diff)
python/python-klein: Renamed python2-klein.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python2-klein')
-rw-r--r--python/python2-klein/README2
-rw-r--r--python/python2-klein/python2-klein.SlackBuild87
-rw-r--r--python/python2-klein/python2-klein.info10
-rw-r--r--python/python2-klein/slack-desc19
4 files changed, 118 insertions, 0 deletions
diff --git a/python/python2-klein/README b/python/python2-klein/README
new file mode 100644
index 0000000000000..e7bb343918a77
--- /dev/null
+++ b/python/python2-klein/README
@@ -0,0 +1,2 @@
+Klein is a micro-framework for developing production-ready web services
+with Python. It has a small API similar to Bottle and Flask.
diff --git a/python/python2-klein/python2-klein.SlackBuild b/python/python2-klein/python2-klein.SlackBuild
new file mode 100644
index 0000000000000..08ef98a2010fa
--- /dev/null
+++ b/python/python2-klein/python2-klein.SlackBuild
@@ -0,0 +1,87 @@
+#!/bin/sh
+
+# Slackware build script for klein
+
+# Copyright 2016 David Spencer, Baildon, West Yorkshire, U.K.
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python2-klein
+VERSION=${VERSION:-17.10.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM="$(printf $PRGNAM | cut -d- -f2-)"
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python2 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS LICENSE NEWS.rst README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python2-klein/python2-klein.info b/python/python2-klein/python2-klein.info
new file mode 100644
index 0000000000000..ef8c057fa5bb3
--- /dev/null
+++ b/python/python2-klein/python2-klein.info
@@ -0,0 +1,10 @@
+PRGNAM="python2-klein"
+VERSION="17.10.0"
+HOMEPAGE="https://klein.readthedocs.io/"
+DOWNLOAD="https://pypi.python.org/packages/94/60/63a2b10f70e2bc949b5280935ab40dd4df8446ea71c1e689a1205970decc/klein-17.10.0.tar.gz"
+MD5SUM="d1bc497cd60870f63415cd0e5aebc0d3"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python2-twisted werkzeug"
+MAINTAINER="David Spencer"
+EMAIL="baildon.research@googlemail.com"
diff --git a/python/python2-klein/slack-desc b/python/python2-klein/slack-desc
new file mode 100644
index 0000000000000..04214ac213684
--- /dev/null
+++ b/python/python2-klein/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-klein: python2-klein (micro-framework for web services)
+python2-klein:
+python2-klein: Klein is a micro-framework for developing production-ready web
+python2-klein: services with Python. It has a small API similar to Bottle and Flask.
+python2-klein:
+python2-klein: https://klein.readthedocs.io/
+python2-klein:
+python2-klein:
+python2-klein:
+python2-klein:
+python2-klein: