aboutsummaryrefslogtreecommitdiff
path: root/python/python2-gattlib
diff options
context:
space:
mode:
authorDave Woodfall <dave@slackbuilds.org>2021-05-06 17:11:18 +0100
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2021-05-08 01:41:48 +0700
commitc6830b5760af44e674cb97ec71e3f14132bd70ff (patch)
treed7861409e19bf64851b568df8f4bcf1a35eade29 /python/python2-gattlib
parent8eec73c9fbe6957dad9a0b3f8edae4dadc01dafc (diff)
downloadslackbuilds-c6830b5760af44e674cb97ec71e3f14132bd70ff.tar.xz
python/python-gattlib: Renamed python2-gattlib.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python2-gattlib')
-rw-r--r--python/python2-gattlib/README3
-rw-r--r--python/python2-gattlib/dont_hardcode_python_versions.patch19
-rw-r--r--python/python2-gattlib/python2-gattlib.SlackBuild75
-rw-r--r--python/python2-gattlib/python2-gattlib.info10
-rw-r--r--python/python2-gattlib/slack-desc19
5 files changed, 126 insertions, 0 deletions
diff --git a/python/python2-gattlib/README b/python/python2-gattlib/README
new file mode 100644
index 000000000000..ab2b73dfa094
--- /dev/null
+++ b/python/python2-gattlib/README
@@ -0,0 +1,3 @@
+This is a Python library to use the GATT Protocol for Bluetooth LE
+devices. It is a wrapper around the implementation used by gatttool
+in bluez package.
diff --git a/python/python2-gattlib/dont_hardcode_python_versions.patch b/python/python2-gattlib/dont_hardcode_python_versions.patch
new file mode 100644
index 000000000000..0e11e85d182c
--- /dev/null
+++ b/python/python2-gattlib/dont_hardcode_python_versions.patch
@@ -0,0 +1,19 @@
+Matteo Bernardini <ponce@slackbuilds.org>
+---
+Don't hardcode python versions
+
+diff -Naur gattlib-0.20150805.orig/setup.py gattlib-0.20150805/setup.py
+--- gattlib-0.20150805.orig/setup.py 2015-08-05 15:16:56.000000000 +0200
++++ gattlib-0.20150805/setup.py 2018-05-02 09:45:04.625893000 +0200
+@@ -19,9 +19,9 @@
+ glib_libs = [x.strip() for x in glib_libs if x]
+
+ if sys.version_info.major == 3:
+- boost_libs = ["boost_python-py34"]
++ boost_libs = ["boost_python3"+str(sys.version_info.minor)]
+ else:
+- boost_libs = ["boost_python"]
++ boost_libs = ["boost_python2"+str(sys.version_info.minor)]
+ extension_modules = [
+ Extension(
+ 'gattlib',
diff --git a/python/python2-gattlib/python2-gattlib.SlackBuild b/python/python2-gattlib/python2-gattlib.SlackBuild
new file mode 100644
index 000000000000..33c25a3835c9
--- /dev/null
+++ b/python/python2-gattlib/python2-gattlib.SlackBuild
@@ -0,0 +1,75 @@
+#!/bin/sh
+
+# Slackware build script for python-gattlib
+
+# Copyright 2017 Heinz Wiesinger, Amsterdam, The Netherlands
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python2-gattlib
+VERSION=${VERSION:-0.20150805}
+BUILD=${BUILD:-2}
+TAG=${TAG:-_SBo}
+
+SRCNAM=gattlib
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 -o -perm 770 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+patch -p1 < $CWD/dont_hardcode_python_versions.patch
+
+python2 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python2-gattlib/python2-gattlib.info b/python/python2-gattlib/python2-gattlib.info
new file mode 100644
index 000000000000..b7f3c2c86983
--- /dev/null
+++ b/python/python2-gattlib/python2-gattlib.info
@@ -0,0 +1,10 @@
+PRGNAM="python2-gattlib"
+VERSION="0.20150805"
+HOMEPAGE="https://bitbucket.org/OscarAcena/pygattlib"
+DOWNLOAD="https://pypi.python.org/packages/be/2f/5b1aecec551b42b59d8b399ad444b5672972efb590ca83d784dbe616a3e1/gattlib-0.20150805.tar.gz"
+MD5SUM="f620eca190bb7acd67c7aafecaedb6c2"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Heinz Wiesinger"
+EMAIL="pprkut@liwjatan.at"
diff --git a/python/python2-gattlib/slack-desc b/python/python2-gattlib/slack-desc
new file mode 100644
index 000000000000..b9d149dfabe8
--- /dev/null
+++ b/python/python2-gattlib/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-gattlib: python2-gattlib (Bluetooth LE protocol library)
+python2-gattlib:
+python2-gattlib: This is a Python library to use the GATT Protocol for Bluetooth LE
+python2-gattlib: devices. It is a wrapper around the implementation used by gatttool
+python2-gattlib: in bluez package.
+python2-gattlib:
+python2-gattlib: Homepage: https://bitbucket.org/OscarAcena/pygattlib
+python2-gattlib:
+python2-gattlib:
+python2-gattlib:
+python2-gattlib: