aboutsummaryrefslogtreecommitdiff
path: root/python/python-zipp
diff options
context:
space:
mode:
authorfourtysixandtwo <fourtysixandtwo@sliderr.net>2023-12-13 10:20:56 -0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-12-16 08:56:15 +0700
commit3464814ed26ca4c49999e5dfb4bf4704e35e2a35 (patch)
tree46106bc5fa8caa1bc739a5dbb550c5b8b2abb247 /python/python-zipp
parent3f96f8e2131cb4f0db229da18b2ae64b21db5a23 (diff)
python/python-zipp: Updated for version 3.17.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python-zipp')
-rw-r--r--python/python-zipp/python-zipp.SlackBuild25
-rw-r--r--python/python-zipp/python-zipp.info8
-rw-r--r--python/python-zipp/setup.py5
3 files changed, 7 insertions, 31 deletions
diff --git a/python/python-zipp/python-zipp.SlackBuild b/python/python-zipp/python-zipp.SlackBuild
index 9c503b35d4f9..6ad17fb9f20d 100644
--- a/python/python-zipp/python-zipp.SlackBuild
+++ b/python/python-zipp/python-zipp.SlackBuild
@@ -27,7 +27,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=python-zipp
-VERSION=${VERSION:-3.8.0}
+VERSION=${VERSION:-3.17.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -51,23 +51,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-elif [ "$ARCH" = "aarch64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -75,7 +58,6 @@ mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $SRCNAM-$VERSION
tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cp $CWD/setup.py $SRCNAM-$VERSION
cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
@@ -84,9 +66,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-sed -i "s,^name =.*$,&\nversion = $VERSION," setup.cfg
-
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/python-zipp/python-zipp.info b/python/python-zipp/python-zipp.info
index 761699211750..213c93842f98 100644
--- a/python/python-zipp/python-zipp.info
+++ b/python/python-zipp/python-zipp.info
@@ -1,10 +1,10 @@
PRGNAM="python-zipp"
-VERSION="3.8.0"
+VERSION="3.17.0"
HOMEPAGE="https://github.com/jaraco/zipp"
-DOWNLOAD="https://files.pythonhosted.org/packages/cc/3c/3e8c69cd493297003da83f26ccf1faea5dd7da7892a0a7c965ac3bcba7bf/zipp-3.8.0.tar.gz"
-MD5SUM="8864ff5ed01cd28755cc87f1443dbc67"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/z/zipp/zipp-3.17.0.tar.gz"
+MD5SUM="a4cf8c530da863c27a04251724436681"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="python3-build python3-wheel"
MAINTAINER="fourtysixandtwo"
EMAIL="fourtysixandtwo@sliderr.net"
diff --git a/python/python-zipp/setup.py b/python/python-zipp/setup.py
deleted file mode 100644
index 0ae4555937eb..000000000000
--- a/python/python-zipp/setup.py
+++ /dev/null
@@ -1,5 +0,0 @@
-from setuptools import setup
-
-
-if __name__ == '__main__':
- setup()