aboutsummaryrefslogtreecommitdiff
path: root/python/python-xrandr
diff options
context:
space:
mode:
authorDave Woodfall <dave@slackbuilds.org>2021-05-03 06:50:20 +0100
committerRobby Workman <rworkman@slackbuilds.org>2021-05-03 01:49:58 -0500
commit3b8d7e22335e3c823413b19e906705e983f26fc3 (patch)
treeeff38df56b265eeea643f5f07610a7f24372d2a6 /python/python-xrandr
parent2902e47b3f36809793909927c8b5932b26375c47 (diff)
python/python-xrandr: Renamed python2-xrandr.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org>
Diffstat (limited to 'python/python-xrandr')
-rw-r--r--python/python-xrandr/README1
-rw-r--r--python/python-xrandr/python-xrandr.SlackBuild88
-rw-r--r--python/python-xrandr/python-xrandr.info10
-rw-r--r--python/python-xrandr/slack-desc19
4 files changed, 0 insertions, 118 deletions
diff --git a/python/python-xrandr/README b/python/python-xrandr/README
deleted file mode 100644
index 59ba76193ffd8..0000000000000
--- a/python/python-xrandr/README
+++ /dev/null
@@ -1 +0,0 @@
-python-xrandr contains bindings for the RandR extension of X.
diff --git a/python/python-xrandr/python-xrandr.SlackBuild b/python/python-xrandr/python-xrandr.SlackBuild
deleted file mode 100644
index ccf23bc6f2ecc..0000000000000
--- a/python/python-xrandr/python-xrandr.SlackBuild
+++ /dev/null
@@ -1,88 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for python-xrandr
-
-# Copyright 2011 Vincent Batts, Vienna, VA, USA
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=python-xrandr
-VERSION=${VERSION:-0.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-#find $PKG/usr/man -type f -exec gzip -9 {} \;
-#for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README* $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-xrandr/python-xrandr.info b/python/python-xrandr/python-xrandr.info
deleted file mode 100644
index ff712cd40a727..0000000000000
--- a/python/python-xrandr/python-xrandr.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-xrandr"
-VERSION="0.1"
-HOMEPAGE="https://launchpad.net/python-xrandr"
-DOWNLOAD="http://launchpad.net/python-xrandr/stable/0.1/+download/python-xrandr-0.1.tar.gz"
-MD5SUM="bcfc2ca0112fd6680a28d27760bd6561"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Vincent Batts"
-EMAIL="vbatts@hashbangbash.com"
diff --git a/python/python-xrandr/slack-desc b/python/python-xrandr/slack-desc
deleted file mode 100644
index f2c8df49fceee..0000000000000
--- a/python/python-xrandr/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-xrandr: python-xrandr (python bindings for X RandR)
-python-xrandr:
-python-xrandr: Bindings for the RandR extesion of X.
-python-xrandr:
-python-xrandr:
-python-xrandr:
-python-xrandr:
-python-xrandr:
-python-xrandr:
-python-xrandr:
-python-xrandr: