aboutsummaryrefslogtreecommitdiff
path: root/python/python-webpack
diff options
context:
space:
mode:
authorB. Watson <urchlay@slackware.uk>2023-05-15 22:01:04 -0400
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-05-20 11:17:39 +0700
commita2d0269e6a2af1f08c7ca0c9881cf6a566252cc7 (patch)
treeeb8bdc848fd4bc677f3f53520b776a1ff26652db /python/python-webpack
parentae656021b3074fdca190671d25e6935b3d6c1642 (diff)
python/python-webpack: Align with template.
Signed-off-by: B. Watson <urchlay@slackware.uk> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python-webpack')
-rw-r--r--python/python-webpack/python-webpack.SlackBuild17
1 files changed, 5 insertions, 12 deletions
diff --git a/python/python-webpack/python-webpack.SlackBuild b/python/python-webpack/python-webpack.SlackBuild
index b3fbe1529fa14..24cf556949e16 100644
--- a/python/python-webpack/python-webpack.SlackBuild
+++ b/python/python-webpack/python-webpack.SlackBuild
@@ -41,15 +41,12 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
fi
-TMP=${TMP:-/tmp}
+TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -68,14 +65,10 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
- # Python 2.7 will be droped in the future.
-if $(python2 -c 'import sys' 2>/dev/null); then
- python2 setup.py install --root=$PKG
-fi
-# Replacement of python-2.x Python3.x check presence and build if found.
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-fi
+# Python 2.7 will be droped in the future.
+python2 setup.py install --root=$PKG
+
+python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION