aboutsummaryrefslogtreecommitdiff
path: root/python/python-pmw
diff options
context:
space:
mode:
authorDave Woodfall <dave@slackbuilds.org>2021-05-06 17:11:22 +0100
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2021-05-08 01:41:50 +0700
commit3589b74c4679ad2d16d58f6790f58c02d377ccdc (patch)
treec3fa5a2183958ed696a528c50fa859136e49a9cc /python/python-pmw
parent6c0dfa094b990f03f19521263a91f0b0250bac9f (diff)
python/python-pmw: Renamed python2-pmw.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python-pmw')
-rw-r--r--python/python-pmw/README12
-rw-r--r--python/python-pmw/python-pmw.SlackBuild87
-rw-r--r--python/python-pmw/python-pmw.info10
-rw-r--r--python/python-pmw/slack-desc19
4 files changed, 0 insertions, 128 deletions
diff --git a/python/python-pmw/README b/python/python-pmw/README
deleted file mode 100644
index 8363f1840dd84..0000000000000
--- a/python/python-pmw/README
+++ /dev/null
@@ -1,12 +0,0 @@
-python-pmw (Python Megawidgets, based on top of Tkinter)
-
-It is a toolkit for building high-level compound widgets in Python
-using the Tkinter module. It consists of a set of base classes and
-a library of flexible and extensible megawidgets built on this
-foundation. These megawidgets include notebooks, comboboxes,
-selection widgets, paned widgets, scrolled widgets and dialog
-windows.
-
-The base classes and most megawidgets were written by Greg McFarlane
-(current maintainer) and Peter Munnings. There are also several
-contributed megawidgets.
diff --git a/python/python-pmw/python-pmw.SlackBuild b/python/python-pmw/python-pmw.SlackBuild
deleted file mode 100644
index f452ea0a08ed0..0000000000000
--- a/python/python-pmw/python-pmw.SlackBuild
+++ /dev/null
@@ -1,87 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for python-pmw
-
-# Copyright 2007-2014 LukenShiro, Italy
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=python-pmw
-VERSION=${VERSION:-1.3.3b}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-SRCPRGNAM=Pmw
-SRCSUBDIR=Pmw_1_3_3
-SRCVERSION=1_3_3b
-
-if [ "$ARCH" = "i486" ]; then
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-mkdir -p $PRGNAM-$VERSION
-cd $PRGNAM-$VERSION
-tar xvf $CWD/${SRCPRGNAM}_${SRCVERSION}.tar.gz
-cd $SRCPRGNAM/$SRCPRGNAM
-chown -R root:root . || true
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# Move documentation files
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-mv README $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-cd ..
-python ./setup.py install --root=$PKG
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-pmw/python-pmw.info b/python/python-pmw/python-pmw.info
deleted file mode 100644
index fd8318477353a..0000000000000
--- a/python/python-pmw/python-pmw.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-pmw"
-VERSION="1.3.3b"
-HOMEPAGE="http://pmw.sourceforge.net"
-DOWNLOAD="http://downloads.sourceforge.net/pmw/Pmw_1_3_3b.tar.gz"
-MD5SUM="d8b998b921584db32a5eeeddc6bc606c"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="LukenShiro"
-EMAIL="lukenshiro@ngi.it"
diff --git a/python/python-pmw/slack-desc b/python/python-pmw/slack-desc
deleted file mode 100644
index d22737ba26a6f..0000000000000
--- a/python/python-pmw/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-pmw: python-pmw (Python Megawidgets, based on top of Tkinter)
-python-pmw:
-python-pmw: It is a toolkit for building high-level compound widgets in
-python-pmw: Python using the Tkinter module. It consists of a set of base
-python-pmw: classes and a library of flexible and extensible megawidgets
-python-pmw: built on this foundation. These megawidgets include notebooks,
-python-pmw: comboboxes, selection widgets, paned widgets, scrolled widgets
-python-pmw: and dialog windows.
-python-pmw:
-python-pmw: Homepage: http://pmw.sourceforge.net/
-python-pmw: