aboutsummaryrefslogtreecommitdiff
path: root/python/python-orbited
diff options
context:
space:
mode:
authorDave Woodfall <dave@slackbuilds.org>2021-05-14 21:34:40 +0100
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2021-05-19 18:40:01 +0700
commit24b8c9b2749002e505b3691ca2872b8ab7ecc319 (patch)
treef29669cf292057e859db30f9536f117a819c7423 /python/python-orbited
parent490cc971a38ecd3b614411b0dab18e6f36507955 (diff)
python/python-orbited: Renamed python2-orbited.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python-orbited')
-rw-r--r--python/python-orbited/README4
-rw-r--r--python/python-orbited/python-orbited.SlackBuild86
-rw-r--r--python/python-orbited/python-orbited.info10
-rw-r--r--python/python-orbited/slack-desc19
4 files changed, 0 insertions, 119 deletions
diff --git a/python/python-orbited/README b/python/python-orbited/README
deleted file mode 100644
index c95814113b23b..0000000000000
--- a/python/python-orbited/README
+++ /dev/null
@@ -1,4 +0,0 @@
-Orbited provides a pure JavaScript/HTML socket in the browser. It is
-a web router and firewall that allows you to integrate web
-applications with arbitrary back-end systems. You can implement any
-network protocol in the browser - without resorting to plugins.
diff --git a/python/python-orbited/python-orbited.SlackBuild b/python/python-orbited/python-orbited.SlackBuild
deleted file mode 100644
index 123c92e5b52c9..0000000000000
--- a/python/python-orbited/python-orbited.SlackBuild
+++ /dev/null
@@ -1,86 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for python-orbited
-
-# Copyright 2010 David Woodfall <dave@slackbuilds.org>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=python-orbited
-VERSION=${VERSION:-0.7.10}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-SRCNAM=orbited
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-python2 setup.py install --root=$PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-orbited/python-orbited.info b/python/python-orbited/python-orbited.info
deleted file mode 100644
index 3928f11e93231..0000000000000
--- a/python/python-orbited/python-orbited.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-orbited"
-VERSION="0.7.10"
-HOMEPAGE="http://orbited.org/"
-DOWNLOAD="https://pypi.python.org/packages/source/o/orbited/orbited-0.7.10.tar.gz"
-MD5SUM="4f4e85d197466c141b1af466782445c1"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python2-demjson python2-morbid python2-stomper python-twisted python2-uuid"
-MAINTAINER="David Woodfall"
-EMAIL="dave@slackbuilds.org"
diff --git a/python/python-orbited/slack-desc b/python/python-orbited/slack-desc
deleted file mode 100644
index 7cf3b1a72cc1d..0000000000000
--- a/python/python-orbited/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-orbited: python-orbited (Realtime Communication for the Browser)
-python-orbited:
-python-orbited: Orbited provides a pure JavaScript/HTML socket in the browser. It is
-python-orbited: a web router and firewall that allows you to integrate web
-python-orbited: applications with arbitrary back-end systems. You can implement any
-python-orbited: network protocol in the browser - without resorting to plugins.
-python-orbited:
-python-orbited: Homepage: http://orbited.org/
-python-orbited:
-python-orbited:
-python-orbited: