aboutsummaryrefslogtreecommitdiff
path: root/python/python-oauth
diff options
context:
space:
mode:
authorDave Woodfall <dave@slackbuilds.org>2021-05-06 17:09:25 +0100
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2021-05-08 01:41:44 +0700
commitfd743313af52c72de96b367b50e3d2ec9808cfd1 (patch)
tree45f7a276830eec0a9edebe286d02cc28c1505051 /python/python-oauth
parente8082337623f36255954d959db07c90907ca490a (diff)
python/python-oauth: Renamed python2-oauth.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python-oauth')
-rw-r--r--python/python-oauth/README2
-rw-r--r--python/python-oauth/python-oauth.SlackBuild88
-rw-r--r--python/python-oauth/python-oauth.info10
-rw-r--r--python/python-oauth/slack-desc19
4 files changed, 0 insertions, 119 deletions
diff --git a/python/python-oauth/README b/python/python-oauth/README
deleted file mode 100644
index 696a32657ac0b..0000000000000
--- a/python/python-oauth/README
+++ /dev/null
@@ -1,2 +0,0 @@
-An open protocol to allow API authentication from desktop and web
-applications.
diff --git a/python/python-oauth/python-oauth.SlackBuild b/python/python-oauth/python-oauth.SlackBuild
deleted file mode 100644
index cf244e86a29b0..0000000000000
--- a/python/python-oauth/python-oauth.SlackBuild
+++ /dev/null
@@ -1,88 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for python-oauth
-# Copyright 2011 David Somero <dsomero@hotmail.com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=python-oauth
-VERSION=${VERSION:-1.0.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-SRCNAM=oauth
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- LICENSE.txt \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-oauth/python-oauth.info b/python/python-oauth/python-oauth.info
deleted file mode 100644
index 51c36a317ff55..0000000000000
--- a/python/python-oauth/python-oauth.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-oauth"
-VERSION="1.0.1"
-HOMEPAGE="http://code.google.com/p/oauth/"
-DOWNLOAD="https://pypi.python.org/packages/source/o/oauth/oauth-1.0.1.tar.gz"
-MD5SUM="30ed3cc8c11d7841a89feab437aabf81"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="David Somero"
-EMAIL="dsomero@hotmail.com"
diff --git a/python/python-oauth/slack-desc b/python/python-oauth/slack-desc
deleted file mode 100644
index c32a141468e1c..0000000000000
--- a/python/python-oauth/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-oauth: python-oauth (open protocol to allow API authentication)
-python-oauth:
-python-oauth: An open protocol to allow API authentication from desktop and
-python-oauth: web applications.
-python-oauth:
-python-oauth:
-python-oauth:
-python-oauth:
-python-oauth:
-python-oauth:
-python-oauth: