aboutsummaryrefslogtreecommitdiff
path: root/python/python-memcached
diff options
context:
space:
mode:
authorDave Woodfall <dave@slackbuilds.org>2021-05-06 17:11:19 +0100
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2021-05-08 01:41:49 +0700
commit21d2f67b66994b33c3e38e9045b4a2edbb9832b5 (patch)
treef8b00ac6ffa84e11936874d5c0fbcb9f384fefce /python/python-memcached
parent3635a560db742506639b41e3967acb783b6d906f (diff)
python/python-memcached: Renamed python2-memcached.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python-memcached')
-rw-r--r--python/python-memcached/README4
-rw-r--r--python/python-memcached/python-memcached.SlackBuild85
-rw-r--r--python/python-memcached/python-memcached.info10
-rw-r--r--python/python-memcached/slack-desc19
4 files changed, 0 insertions, 118 deletions
diff --git a/python/python-memcached/README b/python/python-memcached/README
deleted file mode 100644
index 80f55a7514f1e..0000000000000
--- a/python/python-memcached/README
+++ /dev/null
@@ -1,4 +0,0 @@
-This software is a 100% Python interface to the memcached memory
-cache daemon. It is the client side software which allows storing
-values in one or more, possibly remote, memcached servers. Search
-google for memcached for more information.
diff --git a/python/python-memcached/python-memcached.SlackBuild b/python/python-memcached/python-memcached.SlackBuild
deleted file mode 100644
index 58c17bde24d0b..0000000000000
--- a/python/python-memcached/python-memcached.SlackBuild
+++ /dev/null
@@ -1,85 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for "python-memcached".
-
-# Copyright 2015 Marcel Saegebarth <marc@mos6581.de>
-# Copyright 2016 Dimitris Zlatanidis Orestiada, Greece
-# All rights reserved.
-#
-# Redistribution and use in source and binary forms, with or without
-# modification, are permitted provided that the following conditions are
-# met:
-#
-# * Redistributions of source code must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
-# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
-# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
-# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
-# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
-# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
-# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
-# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
-# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
-# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=python-memcached
-VERSION=${VERSION:-1.58}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-release-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root $PKG
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a ChangeLog PSF.LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-memcached/python-memcached.info b/python/python-memcached/python-memcached.info
deleted file mode 100644
index 172079d209fef..0000000000000
--- a/python/python-memcached/python-memcached.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-memcached"
-VERSION="1.58"
-HOMEPAGE="https://github.com/linsomniac/python-memcached/"
-DOWNLOAD="https://pypi.python.org/packages/f7/62/14b2448cfb04427366f24104c9da97cf8ea380d7258a3233f066a951a8d8/python-memcached-1.58.tar.gz"
-MD5SUM="23b258105013d14d899828d334e6b044"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/python-memcached/slack-desc b/python/python-memcached/slack-desc
deleted file mode 100644
index f089e21945912..0000000000000
--- a/python/python-memcached/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-memcached: python-memcached (Python client for memached)
-python-memcached:
-python-memcached: This software is a 100% Python interface to the memcached memory
-python-memcached: cache daemon. It is the client side software which allows storing
-python-memcached: values in one or more, possibly remote, memcached servers. Search
-python-memcached: google for memcached for more information.
-python-memcached:
-python-memcached: Homepage: https://github.com/linsomniac/python-memcached
-python-memcached:
-python-memcached:
-python-memcached: