aboutsummaryrefslogtreecommitdiff
path: root/python/python-magic/python-magic.SlackBuild
diff options
context:
space:
mode:
authorLarry Hajali <larryhaja[at]gmail[dot]com>2018-11-05 17:14:10 -0800
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2018-11-10 07:48:11 +0700
commitda566759bc9df817b8484cc2b2a1c5af8bb6857a (patch)
treef28c2918edcbf7476a96fdf91f69adc8475a0ebd /python/python-magic/python-magic.SlackBuild
parent8eb584c5511eb9bcd7092bfcf0a1f759a49a629d (diff)
python/python-magic: Updated for version 0.4.15
Signed-off-by: Larry Hajali <larryhaja[at]gmail[dot]com>
Diffstat (limited to 'python/python-magic/python-magic.SlackBuild')
-rw-r--r--python/python-magic/python-magic.SlackBuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/python/python-magic/python-magic.SlackBuild b/python/python-magic/python-magic.SlackBuild
index 433f71f9ffaa..ea78af0ed178 100644
--- a/python/python-magic/python-magic.SlackBuild
+++ b/python/python-magic/python-magic.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for python-magic
-# Copyright 2009-2016 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2009-2018 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=python-magic
-VERSION=${VERSION:-0.4.12}
+VERSION=${VERSION:-0.4.15}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -55,7 +55,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
# Install for python3. Default is no.
if [ "${PYTHON3:-no}" == "yes" ]; then
@@ -67,7 +67,7 @@ find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | gr
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install