aboutsummaryrefslogtreecommitdiff
path: root/python/python-distutils-extra
diff options
context:
space:
mode:
authorWilly Sudiarto Raharjo <willysr@slackbuilds.org>2016-05-07 22:15:31 +0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2016-05-07 22:15:31 +0700
commitab032da3b25846d2b3b6514a83cc3a71af2b9e18 (patch)
tree05cc96c0213b0b31a26a8e6466a660560cb5e733 /python/python-distutils-extra
parent504d46297fc1a4b7144ec8cb6dc93646e9b75265 (diff)
downloadslackbuilds-ab032da3b25846d2b3b6514a83cc3a71af2b9e18.tar.xz
python/python-distutils-extra: Add python3 support.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/python-distutils-extra')
-rw-r--r--python/python-distutils-extra/README4
-rw-r--r--python/python-distutils-extra/python-distutils-extra.SlackBuild5
2 files changed, 9 insertions, 0 deletions
diff --git a/python/python-distutils-extra/README b/python/python-distutils-extra/README
index 5e652e923fb6..90754780d3c5 100644
--- a/python/python-distutils-extra/README
+++ b/python/python-distutils-extra/README
@@ -2,3 +2,7 @@ Python-distutils-extra allows to easily integrate themable icons,
scrollkeeper based documentation, and gettext based translations in
your python install and build tools. It can be used with python's
distutils or the enhanced setuptools.
+
+To install python3 bindings run the slackbuild with PYTHON3=yes.
+
+ # PYTHON3=yes ./python-distutils-extra.SlackBuild
diff --git a/python/python-distutils-extra/python-distutils-extra.SlackBuild b/python/python-distutils-extra/python-distutils-extra.SlackBuild
index 1109d09f637d..9e25ef75a723 100644
--- a/python/python-distutils-extra/python-distutils-extra.SlackBuild
+++ b/python/python-distutils-extra/python-distutils-extra.SlackBuild
@@ -57,6 +57,11 @@ find -L . \
python setup.py install --root=$PKG
+# Install python3 bindings for distutils-extra. Default is no.
+if [ "${PYTHON3:-no}" == "yes" ]; then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true