aboutsummaryrefslogtreecommitdiff
path: root/python/python-bigfloat
diff options
context:
space:
mode:
authorDave Woodfall <dave@slackbuilds.org>2021-05-03 06:48:49 +0100
committerRobby Workman <rworkman@slackbuilds.org>2021-05-03 01:49:56 -0500
commita4d9e3e216437f6c188d073e87d16b758179e9c1 (patch)
treeb7f53321837200027c755cc405b2700bc1607029 /python/python-bigfloat
parent1b12b817b6a1bcb69cbbb3d1a2e854ae5a4667a0 (diff)
python/python-bigfloat: Renamed python2-bigfloat.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org>
Diffstat (limited to 'python/python-bigfloat')
-rw-r--r--python/python-bigfloat/README16
-rw-r--r--python/python-bigfloat/doinst.sh3
-rw-r--r--python/python-bigfloat/python-bigfloat.SlackBuild71
-rw-r--r--python/python-bigfloat/python-bigfloat.info10
-rw-r--r--python/python-bigfloat/slack-desc19
5 files changed, 0 insertions, 119 deletions
diff --git a/python/python-bigfloat/README b/python/python-bigfloat/README
deleted file mode 100644
index a66784f717f9b..0000000000000
--- a/python/python-bigfloat/README
+++ /dev/null
@@ -1,16 +0,0 @@
-The bigfloat module is a Python wrapper for the MPFR library for arbitrary
-precision floating-point reliable arithmetic.
-
-The MPFR library is a well-known portable C library for arbitrary-precision
-arithmetic on floating-point numbers. It provides precise control over
-precisions and rounding modes and gives correctly-rounded reproducible
-platform-independent results.
-
-The bigfloat module aims to provide a convenient and friendly Python
-interface to the operations and functions provided by the MPFR library. The
-main class, BigFloat, gives an immutable multiple-precision floating-point
-type that can be freely mixed with Python integers and floats. The Context
-class, when used in conjunction with Pythons with statement, gives a simple
-way of controlling precisions and rounding modes. Additional module-level
-functions provide various standard mathematical operations. There is full
-support for IEEE 754 signed zeros, nans, infinities and subnormals.
diff --git a/python/python-bigfloat/doinst.sh b/python/python-bigfloat/doinst.sh
deleted file mode 100644
index c9ae7e166cc38..0000000000000
--- a/python/python-bigfloat/doinst.sh
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/bash
-
-python -m bigfloat.test.test_bigfloat
diff --git a/python/python-bigfloat/python-bigfloat.SlackBuild b/python/python-bigfloat/python-bigfloat.SlackBuild
deleted file mode 100644
index 4d6b18334b4aa..0000000000000
--- a/python/python-bigfloat/python-bigfloat.SlackBuild
+++ /dev/null
@@ -1,71 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for python-bigfloat
-
-# Written by John Tyree <johntyree@gmail.com>
-
-PRGNAM=python-bigfloat
-VERSION=${VERSION:-0.3.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-SRCNAM=$(echo $PRGNAM | cut -d- -f2)
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-mv $SRCNAM-$VERSION $PRGNAM-$VERSION
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a COPYING* *.rst $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -p -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-bigfloat/python-bigfloat.info b/python/python-bigfloat/python-bigfloat.info
deleted file mode 100644
index c34c5656c4bed..0000000000000
--- a/python/python-bigfloat/python-bigfloat.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-bigfloat"
-VERSION="0.3.0"
-HOMEPAGE="https://github.com/mdickinson/bigfloat/"
-DOWNLOAD="https://github.com/mdickinson/bigfloat/archive/v0.3.0/bigfloat-0.3.0.tar.gz"
-MD5SUM="fe976782d4c969f11b806e8ff2706d79"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="John Tyree"
-EMAIL="johntyree+removethis@gmail.com"
diff --git a/python/python-bigfloat/slack-desc b/python/python-bigfloat/slack-desc
deleted file mode 100644
index 238d503746172..0000000000000
--- a/python/python-bigfloat/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-bigfloat: python-bigfloat (Arbitrary precision floating point arithmetic)
-python-bigfloat:
-python-bigfloat: The bigfloat module is a Python wrapper for the MPFR library for
-python-bigfloat: arbitrary precision floating-point reliable arithmetic.
-python-bigfloat:
-python-bigfloat: The MPFR library is a well-known portable C library for
-python-bigfloat: arbitrary-precision arithmetic on floating-point numbers. It provides
-python-bigfloat: precise control over precisions and rounding modes and gives
-python-bigfloat: correctly-rounded reproducible platform-independent results.
-python-bigfloat:
-python-bigfloat: