aboutsummaryrefslogtreecommitdiff
path: root/python/python-authres
diff options
context:
space:
mode:
authorDave Woodfall <dave@slackbuilds.org>2021-05-03 06:48:49 +0100
committerRobby Workman <rworkman@slackbuilds.org>2021-05-03 01:49:56 -0500
commit1b12b817b6a1bcb69cbbb3d1a2e854ae5a4667a0 (patch)
tree54cf7a5b1984e0debd79486016d771b9d4a197e6 /python/python-authres
parentfd0f91c27371a92ffaf538e1a8e46f5bf1bedb04 (diff)
python/python-authres: Renamed python2-authres.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org>
Diffstat (limited to 'python/python-authres')
-rw-r--r--python/python-authres/README7
-rw-r--r--python/python-authres/python-authres.SlackBuild73
-rw-r--r--python/python-authres/python-authres.info10
-rw-r--r--python/python-authres/slack-desc19
4 files changed, 0 insertions, 109 deletions
diff --git a/python/python-authres/README b/python/python-authres/README
deleted file mode 100644
index de1c8ff5062ca..0000000000000
--- a/python/python-authres/README
+++ /dev/null
@@ -1,7 +0,0 @@
-RFC 5451 Authentication-Results Headers generation and parsing for
-Python/Python3.
-
-It also supports Authentication Results extensions:
- * RFC 5617 DKIM/ADSP
- * RFC 6008 DKIM signature identification (header.b)
- * RFC 6212 Vouch By Reference (VBR)
diff --git a/python/python-authres/python-authres.SlackBuild b/python/python-authres/python-authres.SlackBuild
deleted file mode 100644
index 1f4935f600d3a..0000000000000
--- a/python/python-authres/python-authres.SlackBuild
+++ /dev/null
@@ -1,73 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for python-authres
-
-# Copyright 2013 Chris Walker Copperas Cove, TX
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=python-authres
-VERSION=${VERSION:-0.501}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-SRCNAM=authres
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-/usr/bin/python setup.py install --root $PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGES COPYING README $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/python-authres/python-authres.info b/python/python-authres/python-authres.info
deleted file mode 100644
index 10a7fb9e088ac..0000000000000
--- a/python/python-authres/python-authres.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="python-authres"
-VERSION="0.501"
-HOMEPAGE="https://launchpad.net/authentication-results-python"
-DOWNLOAD="https://launchpad.net/authentication-results-python/0.5/0.501/+download/authres-0.501.tar.gz"
-MD5SUM="b3f51965d5b1326f7268515457ef4023"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Christopher Walker"
-EMAIL="kris240376@gmail.com"
diff --git a/python/python-authres/slack-desc b/python/python-authres/slack-desc
deleted file mode 100644
index c439733750a0a..0000000000000
--- a/python/python-authres/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-authres: python-authres (RFC 5451 Auth Results Headers generation and parsing)
-python-authres:
-python-authres: RFC 5451 Authentication-Results Headers generation and parsing for
-python-authres: Python/Python3.
-python-authres:
-python-authres: It also supports Authentication Results extensions:
-python-authres: * RFC 5617 DKIM/ADSP
-python-authres: * RFC 6008 DKIM signature identification (header.b)
-python-authres: * RFC 6212 Vouch By Reference (VBR)
-python-authres:
-python-authres: Homepage: https://launchpad.net/authentication-results-python