aboutsummaryrefslogtreecommitdiff
path: root/python/pluggy/pluggy.SlackBuild
diff options
context:
space:
mode:
authorDimitris Zlatanidis <d.zlatanidis@gmail.com>2018-10-08 18:56:04 +0200
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2018-10-13 08:03:06 +0700
commit13d295eb04db7d5d693aa989ae49b364f9d244dc (patch)
tree1f42aadbc232c6239cf6b48a61d206e9bc6acbe7 /python/pluggy/pluggy.SlackBuild
parent05a47ad6135cb9dfe4777a0758cf870267aa2120 (diff)
python/pluggy: Added support python3.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com>
Diffstat (limited to 'python/pluggy/pluggy.SlackBuild')
-rw-r--r--python/pluggy/pluggy.SlackBuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/python/pluggy/pluggy.SlackBuild b/python/pluggy/pluggy.SlackBuild
index c1cf7f489acf..ad7d78bd096c 100644
--- a/python/pluggy/pluggy.SlackBuild
+++ b/python/pluggy/pluggy.SlackBuild
@@ -71,6 +71,11 @@ find -L . \
python setup.py install --root=$PKG
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true