aboutsummaryrefslogtreecommitdiff
path: root/python/pipdeptree
diff options
context:
space:
mode:
authorfourtysixandtwo <fourtysixandtwo@sliderr.net>2023-09-12 18:22:55 -0600
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-09-17 00:10:33 +0700
commitb37bbe55ecddc90db2f2b587c07a6316ff742150 (patch)
tree37cbbdcdd384d6982d9562eaed36ff574c2c193c /python/pipdeptree
parent598182039fb2514546873ffe6e5eabaac957dbd5 (diff)
python/pipdeptree: Updated for version 2.13.0, new maintainer.
With permission from Dimitris Z. Relies on new build python3-setuptools-scm-opt being accepted. Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/pipdeptree')
-rw-r--r--python/pipdeptree/README2
-rw-r--r--python/pipdeptree/pipdeptree.SlackBuild23
-rw-r--r--python/pipdeptree/pipdeptree.info12
3 files changed, 23 insertions, 14 deletions
diff --git a/python/pipdeptree/README b/python/pipdeptree/README
index fb33f30749e1b..2bff59fac240e 100644
--- a/python/pipdeptree/README
+++ b/python/pipdeptree/README
@@ -4,3 +4,5 @@ tree. Since 'pip freeze' shows all dependencies as a flat list,
finding out which are the top level packages and which packages do
they depend on requires some effort. This utility tries to solve this
problem.
+
+Note: All required deps are build only deps.
diff --git a/python/pipdeptree/pipdeptree.SlackBuild b/python/pipdeptree/pipdeptree.SlackBuild
index 65bd28eeb48a2..a5848fb96ebea 100644
--- a/python/pipdeptree/pipdeptree.SlackBuild
+++ b/python/pipdeptree/pipdeptree.SlackBuild
@@ -2,6 +2,7 @@
# Slackware build script for pipdeptree
+# Copyright 2023 fourtysixandtwo <fourtysixandtwo@sliderr.net>
# Copyright 2014-2022 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
@@ -22,10 +23,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20230912 46and2: New maintainer, build process change.
+# -uses updated setuptools-scm to fix __version__ issue
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=pipdeptree
-VERSION=${VERSION:-2.2.1}
+VERSION=${VERSION:-2.13.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +42,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -59,6 +60,9 @@ elif [ "$ARCH" = "i686" ]; then
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
@@ -75,17 +79,20 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
+
+export PYTHONPATH=/opt/python3.9/site-packages/
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a PKG-INFO README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES.md LICENSE PKG-INFO README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/python/pipdeptree/pipdeptree.info b/python/pipdeptree/pipdeptree.info
index d026bb86ded65..9db830594b001 100644
--- a/python/pipdeptree/pipdeptree.info
+++ b/python/pipdeptree/pipdeptree.info
@@ -1,10 +1,10 @@
PRGNAM="pipdeptree"
-VERSION="2.2.1"
+VERSION="2.13.0"
HOMEPAGE="https://github.com/naiquevin/pipdeptree"
-DOWNLOAD="https://files.pythonhosted.org/packages/9e/c0/2ca9cb24d8045a1c84bdeca2b2646fcf438266a930301a7672c4cb8d0ff9/pipdeptree-2.2.1.tar.gz"
-MD5SUM="05cab13fbae0ebb7015a6ce6757000e7"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/p/pipdeptree/pipdeptree-2.13.0.tar.gz"
+MD5SUM="81cd41faa97765062deee804956d53fd"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
+REQUIRES="python3-setuptools-scm-opt python3-hatch_vcs"
+MAINTAINER="fourtysixandtwo"
+EMAIL="fourtysixandtwo@sliderr.net"