aboutsummaryrefslogtreecommitdiff
path: root/python/paramiko
diff options
context:
space:
mode:
authorHeinz Wiesinger <pprkut@slackbuilds.org>2022-01-23 10:50:51 +0100
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-01-25 14:44:38 +0700
commit442c1c3a9dec40d955525be2ff8e1535598e6e1b (patch)
tree34f1f824ad63c57646325391d5242962deaf5a11 /python/paramiko
parent1ba98bfcacf3bff46c85201d3916dd3ab7ba9a3c (diff)
python2-paramiko: Renamed from paramiko and updated to 2.9.2
Signed-off-by: Heinz Wiesinger <pprkut@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/paramiko')
-rw-r--r--python/paramiko/README6
-rw-r--r--python/paramiko/paramiko.SlackBuild81
-rw-r--r--python/paramiko/paramiko.info10
-rw-r--r--python/paramiko/slack-desc19
4 files changed, 0 insertions, 116 deletions
diff --git a/python/paramiko/README b/python/paramiko/README
deleted file mode 100644
index 580e46a714ccf..0000000000000
--- a/python/paramiko/README
+++ /dev/null
@@ -1,6 +0,0 @@
-"paramiko" is a combination of the esperanto words for "paranoid"
-and "friend". it's a module for python 2.2+ that implements the
-SSH2 protocol for secure (encrypted and authenticated) connections
-to remote machines. Unlike SSL (aka TLS), SSH2 protocol does not
-require heirarchical certificates signed by a powerful central
-authority.
diff --git a/python/paramiko/paramiko.SlackBuild b/python/paramiko/paramiko.SlackBuild
deleted file mode 100644
index a5ad1b2000c63..0000000000000
--- a/python/paramiko/paramiko.SlackBuild
+++ /dev/null
@@ -1,81 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for paramiko
-
-# Copyright 2008-2018 Heinz Wiesinger, Amsterdam, The Netherlands
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=paramiko
-VERSION=${VERSION:-2.4.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python2 setup.py install --root=$PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE PKG-INFO README.rst docs $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/paramiko/paramiko.info b/python/paramiko/paramiko.info
deleted file mode 100644
index c967e8ab88851..0000000000000
--- a/python/paramiko/paramiko.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="paramiko"
-VERSION="2.4.1"
-HOMEPAGE="http://www.paramiko.org/"
-DOWNLOAD="https://pypi.python.org/packages/29/65/83181630befb17cd1370a6abb9a87957947a43c2332216e5975353f61d64/paramiko-2.4.1.tar.gz"
-MD5SUM="f9fa1204f706767b6c179effa7c0fb9e"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="cryptography"
-MAINTAINER="Heinz Wiesinger"
-EMAIL="pprkut@slackbuilds.org"
diff --git a/python/paramiko/slack-desc b/python/paramiko/slack-desc
deleted file mode 100644
index e5488fbac7c60..0000000000000
--- a/python/paramiko/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-paramiko: paramiko (Python SSH module)
-paramiko:
-paramiko: "paramiko" is a combination of the esperanto words for "paranoid"
-paramiko: and "friend". it's a module for python 2.2+ that implements the
-paramiko: SSH2 protocol for secure (encrypted and authenticated) connections
-paramiko: to remote machines. Unlike SSL (aka TLS), SSH2 protocol does not
-paramiko: require heirarchical certificates signed by a powerful central
-paramiko: authority.
-paramiko:
-paramiko: Homepage: http://www.lag.net/paramiko/
-paramiko: