aboutsummaryrefslogtreecommitdiff
path: root/python/jsonpointer/jsonpointer.SlackBuild
diff options
context:
space:
mode:
authorIsaac Yu <isaacyu1@isaacyu1.com>2022-12-20 23:54:22 -0800
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-12-23 00:12:24 +0700
commitf5b2344e28a2cbb47efcb447726d27aeaf21d2fa (patch)
treef31357195246cfc1da65e88778155470ff35e953 /python/jsonpointer/jsonpointer.SlackBuild
parent36de606fea4413be1c22446cd53f8473ff6272df (diff)
python/jsonpointer: Update for 2.3 (+new maintainer)
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/jsonpointer/jsonpointer.SlackBuild')
-rw-r--r--python/jsonpointer/jsonpointer.SlackBuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/python/jsonpointer/jsonpointer.SlackBuild b/python/jsonpointer/jsonpointer.SlackBuild
index 413aea70dc1f9..41126baf5a68b 100644
--- a/python/jsonpointer/jsonpointer.SlackBuild
+++ b/python/jsonpointer/jsonpointer.SlackBuild
@@ -2,7 +2,8 @@
# Slackware build script for jsonpointer
-# Copyright 2020 Alan Aversa
+# Copyright 2020 Alan Aversa <alan_avNOersa@lSPAMavabit.com>
+# Copyright 2022 Isaac Yu <isaacyu1@isaacyu1.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=jsonpointer
-VERSION=${VERSION:-2.0}
+VERSION=${VERSION:-2.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -79,16 +80,13 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-if $(python3 -c 'import sys' 2>/dev/null); then
- python3 setup.py install --root=$PKG
-else
- python setup.py install --root=$PKG
-fi
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS LICENSE.txt README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install