aboutsummaryrefslogtreecommitdiff
path: root/python/coverage/coverage.SlackBuild
diff options
context:
space:
mode:
authorDimitris Zlatanidis <d.zlatanidis@gmail.com>2022-02-16 17:46:16 +0200
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-02-17 12:59:47 +0700
commit2b884fb4a49a505348e40e588cc88c8acff7689a (patch)
tree33dba88350529a764377de58b9e051853eb09716 /python/coverage/coverage.SlackBuild
parentaefe43415ac898c7b426135947cd4f59fbf972ce (diff)
python/coverage: Updated for version 6.3.1.
Signed-off-by: Dimitris Zlatanidis <d.zlatanidis@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/coverage/coverage.SlackBuild')
-rw-r--r--python/coverage/coverage.SlackBuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/python/coverage/coverage.SlackBuild b/python/coverage/coverage.SlackBuild
index bc794c2575bf3..3eccb0873ca0c 100644
--- a/python/coverage/coverage.SlackBuild
+++ b/python/coverage/coverage.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for coverage
-# Copyright 2014-2018 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2014-2022 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=coverage
-VERSION=${VERSION:-4.5.1}
+VERSION=${VERSION:-6.3.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -79,7 +79,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true