aboutsummaryrefslogtreecommitdiff
path: root/python/alabaster/alabaster.SlackBuild
diff options
context:
space:
mode:
authorNikos Giotis <nikos.giotis@gmail.com>2018-02-13 16:38:43 +0000
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2018-02-17 07:42:55 +0700
commitef03b97f3c6292eee97065807ac89ae7a2f13f4f (patch)
tree54eb60d16b92e9fd8282d72f288d5bd7efc6cfd7 /python/alabaster/alabaster.SlackBuild
parent903033b4924ee621f8c1b97a51a95fc5f123a8bb (diff)
python/alabaster: Updated for version 0.7.10.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'python/alabaster/alabaster.SlackBuild')
-rw-r--r--python/alabaster/alabaster.SlackBuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/python/alabaster/alabaster.SlackBuild b/python/alabaster/alabaster.SlackBuild
index e06452d8395cc..14609215fc972 100644
--- a/python/alabaster/alabaster.SlackBuild
+++ b/python/alabaster/alabaster.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=alabaster
-VERSION=${VERSION:-0.7.9}
+VERSION=${VERSION:-0.7.10}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -71,6 +71,10 @@ find -L . \
python setup.py install --root=$PKG
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true