aboutsummaryrefslogtreecommitdiff
path: root/python/XlsxWriter/XlsxWriter.SlackBuild
diff options
context:
space:
mode:
authorBarry J. Grundy <bgrundyat>2022-05-20 05:13:29 +0100
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-05-21 08:25:22 +0700
commitc9bd188e068aa75ef3e7e50292074b4fddc45e01 (patch)
treebfca85420ae7d1ee864c9629f8cf4b6be5193d19 /python/XlsxWriter/XlsxWriter.SlackBuild
parent21d44b301d5a78660963a71e37da69cb2038c114 (diff)
python/XlsxWriter: Updated for version 3.0.3.
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/XlsxWriter/XlsxWriter.SlackBuild')
-rw-r--r--python/XlsxWriter/XlsxWriter.SlackBuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/python/XlsxWriter/XlsxWriter.SlackBuild b/python/XlsxWriter/XlsxWriter.SlackBuild
index 447303c13e009..75b4c986a9b96 100644
--- a/python/XlsxWriter/XlsxWriter.SlackBuild
+++ b/python/XlsxWriter/XlsxWriter.SlackBuild
@@ -1,7 +1,7 @@
#!/bin/bash
# Slackware build script for XlsxWriter
-# Copyright 2019 Barry Grundy <bgrundy[at]linuxleo.com>
+# Copyright 2019-2022 Barry Grundy <bgrundy[at]linuxleo.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -21,12 +21,12 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
#
-# Updated for version 1.1.2, Feb 2019
+# Updated for version 3.0.3 May 2022
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=XlsxWriter
-VERSION=${VERSION:-1.1.2}
+VERSION=${VERSION:-3.0.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -80,7 +80,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true