aboutsummaryrefslogtreecommitdiff
path: root/python/Routes
diff options
context:
space:
mode:
authorArn0 <yth@ythogtha.org>2022-03-08 23:11:00 +0100
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2022-03-09 09:45:58 +0700
commit7151462c1387251203df19f7401a51e5d429bcb5 (patch)
treeac30b79a1233d8fbcd9ee858a86d29d7e35fc917 /python/Routes
parent2dbccc389685fbbcc0b3a29ccc5ce82c3317486a (diff)
python/python3-routes: renamed from Routes for python3, updated for version 2.5.1
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/Routes')
-rw-r--r--python/Routes/README9
-rw-r--r--python/Routes/Routes.SlackBuild77
-rw-r--r--python/Routes/Routes.info10
-rw-r--r--python/Routes/slack-desc19
4 files changed, 0 insertions, 115 deletions
diff --git a/python/Routes/README b/python/Routes/README
deleted file mode 100644
index 19ea690829206..0000000000000
--- a/python/Routes/README
+++ /dev/null
@@ -1,9 +0,0 @@
-Routes is a Python re-implementation of the Rails routes system for
-mapping URLs to application actions, and conversely to generate URLs.
-Routes makes it easy to create pretty and concise URLs that are RESTful
-with little effort.
-
-Routes allows conditional matching based on domain, cookies, HTTP
-method, or a custom function.
-Sub-domain support is built in.
-Routes comes with an extensive unit test suite.
diff --git a/python/Routes/Routes.SlackBuild b/python/Routes/Routes.SlackBuild
deleted file mode 100644
index 791bbad29b863..0000000000000
--- a/python/Routes/Routes.SlackBuild
+++ /dev/null
@@ -1,77 +0,0 @@
-#!/bin/bash
-
-# SlackBuild script for Routes.
-# Yth | Pont-en-Royans, France | yth@ythogtha.org
-
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=Routes
-VERSION=${VERSION:-2.4.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python2 setup.py install --root=$PKG
-python3 setup.py install --root=$PKG
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README.rst MANIFEST.in $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/Routes/Routes.info b/python/Routes/Routes.info
deleted file mode 100644
index 87c3f2ef926a3..0000000000000
--- a/python/Routes/Routes.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="Routes"
-VERSION="2.4.1"
-HOMEPAGE="https://routes.readthedocs.io/"
-DOWNLOAD="https://pypi.python.org/packages/source/R/Routes/Routes-2.4.1.tar.gz"
-MD5SUM="c058dff6832941dec47e0d0052548ad8"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="repoze.lru"
-MAINTAINER="Yth - Arnaud"
-EMAIL="yth@ythogtha.org"
diff --git a/python/Routes/slack-desc b/python/Routes/slack-desc
deleted file mode 100644
index f5340569cf523..0000000000000
--- a/python/Routes/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-Routes: Routes (Python Re-Implementation of Rails)
-Routes:
-Routes: Routes is a Python re-implementation of the Rails routes system for
-Routes: mapping URLs to application actions, and conversely to generate URLs.
-Routes:
-Routes: Routes makes it easy to create pretty and concise URLs that are
-Routes: RESTful with little effort.
-Routes: Routes allows conditional matching based on domain, cookies, HTTP
-Routes: method, or a custom function.
-Routes: Sub-domain support is built in.
-Routes: Routes comes with an extensive unit test suite.