aboutsummaryrefslogtreecommitdiff
path: root/python/PyStemmer/PyStemmer.SlackBuild
diff options
context:
space:
mode:
authorAndrew Clemons <andrew.clemons@gmail.com>2021-07-25 18:34:11 +1200
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2021-07-25 16:56:07 +0700
commit5ec56aa1be402f03e693a7a7526868a0f0cd906d (patch)
tree1f153a16d4c9b0fe56d72599714ac5a327e2bb7e /python/PyStemmer/PyStemmer.SlackBuild
parent08cadb35d208d8e84ffbbb680fc5b3571ebc3505 (diff)
python/PyStemmer: Updated for version 2.0.1.
This fixes building on -current. Signed-off-by: Andrew Clemons <andrew.clemons@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/PyStemmer/PyStemmer.SlackBuild')
-rw-r--r--python/PyStemmer/PyStemmer.SlackBuild12
1 files changed, 3 insertions, 9 deletions
diff --git a/python/PyStemmer/PyStemmer.SlackBuild b/python/PyStemmer/PyStemmer.SlackBuild
index 58c11442d12e8..dc0c20a2d48e4 100644
--- a/python/PyStemmer/PyStemmer.SlackBuild
+++ b/python/PyStemmer/PyStemmer.SlackBuild
@@ -25,8 +25,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=PyStemmer
-VERSION=${VERSION:-1.3.0}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-2.0.1}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -73,10 +73,6 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
-# Patch for python 3.7 compatibility
-# https://github.com/snowballstem/pystemmer/pull/21/commits/b29ce2109f49c0b82517fa9d3e2bbacc1f8b34ec
-patch < $CWD/python-3.7-compatibility.patch
-
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -84,9 +80,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-
-#CFLAGS="$SLKCFLAGS" \
+python2 setup.py install --root=$PKG
python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \