aboutsummaryrefslogtreecommitdiff
path: root/python/PyGreSQL
diff options
context:
space:
mode:
authorChristoph Willing <chris.willing@linux.com>2023-12-30 19:26:46 +1000
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-01-06 08:08:51 +0700
commit4878e16a1db0a783d432ea263f590f514dcc95d1 (patch)
treed2e3d616d279d63948dd1acaa6da77822953f406 /python/PyGreSQL
parentcbc5ad6009ca57bc4ca49ca0feb6f1497d83e254 (diff)
python/PyGreSQL: Updated for version 6.0
Signed-off-by: Christoph Willing <chris.willing@linux.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'python/PyGreSQL')
-rw-r--r--python/PyGreSQL/PyGreSQL.SlackBuild17
-rw-r--r--python/PyGreSQL/PyGreSQL.info6
-rw-r--r--python/PyGreSQL/README3
3 files changed, 7 insertions, 19 deletions
diff --git a/python/PyGreSQL/PyGreSQL.SlackBuild b/python/PyGreSQL/PyGreSQL.SlackBuild
index 8827266d620f9..f1b487b603922 100644
--- a/python/PyGreSQL/PyGreSQL.SlackBuild
+++ b/python/PyGreSQL/PyGreSQL.SlackBuild
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=PyGreSQL
-VERSION=${VERSION:-5.2.5}
+VERSION=${VERSION:-6.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -47,20 +47,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -ev
rm -rf $PKG
@@ -77,7 +63,6 @@ find -L . \
-exec chmod 644 {} \;
# Build & install
-python2 setup.py install --root=$PKG
python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
diff --git a/python/PyGreSQL/PyGreSQL.info b/python/PyGreSQL/PyGreSQL.info
index 193dbafc81c24..bf50db10b497a 100644
--- a/python/PyGreSQL/PyGreSQL.info
+++ b/python/PyGreSQL/PyGreSQL.info
@@ -1,8 +1,8 @@
PRGNAM="PyGreSQL"
-VERSION="5.2.5"
+VERSION="6.0"
HOMEPAGE="http://www.pygresql.org"
-DOWNLOAD="https://github.com/PyGreSQL/PyGreSQL/archive/5.2.5/PyGreSQL-5.2.5.tar.gz"
-MD5SUM="60ceff99d8614be345f345159bdaceb5"
+DOWNLOAD="https://github.com/PyGreSQL/PyGreSQL/archive/6.0/PyGreSQL-6.0.tar.gz"
+MD5SUM="5506a20d736b9fe014a790826bdb2090"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="postgresql"
diff --git a/python/PyGreSQL/README b/python/PyGreSQL/README
index 8bd3788b777cc..c816944682415 100644
--- a/python/PyGreSQL/README
+++ b/python/PyGreSQL/README
@@ -1,3 +1,6 @@
PyGreSQL is an open-source Python module that interfaces to a
PostgreSQL database. It embeds the PostgreSQL query library to allow
easy use of the powerful PostgreSQL features from a Python script.
+
+For version 6.0, only Python versions 3.7 to 3.12 and
+PostgreSQL versions 10 to 16 on the server are supported.