aboutsummaryrefslogtreecommitdiff
path: root/office
diff options
context:
space:
mode:
authorTim Dickson <dickson.tim@googlemail.com>2024-07-25 12:24:36 +0100
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2024-07-26 12:03:38 +0700
commitce2eb8ad27df603feecf6e5d6b95de46a204562c (patch)
treeccc15b34dd630319b62b82cb8d96c396849b7a98 /office
parent24729b4b1b59df86f213318833eed725d3ec4c78 (diff)
office/gnucash: add webkit2gtk4.1 support
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'office')
-rw-r--r--office/gnucash/README2
-rw-r--r--office/gnucash/gnucash.SlackBuild8
2 files changed, 9 insertions, 1 deletions
diff --git a/office/gnucash/README b/office/gnucash/README
index 50543f280047..83c7d161521f 100644
--- a/office/gnucash/README
+++ b/office/gnucash/README
@@ -16,3 +16,5 @@ Pass WITHPYTHON="yes" to enable Python bindings for report gereration.
If you want the SQL database integration, you must first have libdbi
and libdbi-drivers installed and pass DBI="yes" to the build script.
+
+to build with webkit2gtk4.1, yelp needs to be built with webkit2gtk4.1
diff --git a/office/gnucash/gnucash.SlackBuild b/office/gnucash/gnucash.SlackBuild
index 282dadf39ca8..c4d74d46a50a 100644
--- a/office/gnucash/gnucash.SlackBuild
+++ b/office/gnucash/gnucash.SlackBuild
@@ -27,7 +27,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=gnucash
VERSION=${VERSION:-4.11}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -119,6 +119,12 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+if $(pkg-config --exists webkit2gtk4.1); then
+ #use webkit2gtk4.1 instead of webkit2gtk if present.
+ sed -i 's/webkit2gtk-4.0/webkit2gtk-4.1/g' CMakeLists.txt
+ sed -i 's/WebKit2Gtk4/WebKit2Gtk4.1/g' CMakeLists.txt
+fi
+
mkdir -p build
cd build
cmake \