aboutsummaryrefslogtreecommitdiff
path: root/office
diff options
context:
space:
mode:
authorJohannes Schoepfer <slackbuilds@schoepfer.info>2023-06-10 08:26:49 +0700
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-06-10 08:27:42 +0700
commit3972157033e4a9ce9c7951bee14b40168095a31e (patch)
treeba1dffe0fb9c7cae86a0b9cfa6e8ed1db8976fc9 /office
parent3bb8bfcb00329bff0784bcb99b47d5cd6ede01c2 (diff)
office/asymptote: Updated for version 2.85.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'office')
-rw-r--r--office/asymptote/README3
-rw-r--r--office/asymptote/asymptote.SlackBuild38
-rw-r--r--office/asymptote/asymptote.info8
3 files changed, 34 insertions, 15 deletions
diff --git a/office/asymptote/README b/office/asymptote/README
index 5c81751106106..300ccd79eca03 100644
--- a/office/asymptote/README
+++ b/office/asymptote/README
@@ -4,3 +4,6 @@ Labels and equations are typeset with LaTeX, for high-quality PostScript
output.
A major advantage of Asymptote over other graphics packages is that it
is a programming language as opposed to just a graphics program.
+
+To build the complete documentation, install texlive-extra and set
+DOC=yes
diff --git a/office/asymptote/asymptote.SlackBuild b/office/asymptote/asymptote.SlackBuild
index b3fc58ca1b2c8..09f587df78896 100644
--- a/office/asymptote/asymptote.SlackBuild
+++ b/office/asymptote/asymptote.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for asymptote
-# Copyright 2016 - 2022 Johannes Schoepfer, Germany
+# Copyright 2016-2023 Johannes Schoepfer, Germany
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=asymptote
-VERSION=${VERSION:-2.70}
+VERSION=${VERSION:-2.85}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +38,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -75,9 +72,12 @@ cd asymptote-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} + -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} +
+
+# make documenation optional, as it generates ~/.asy and ~/.texlive20xx
+DOC=${DOC:-no}
CFLAGS="$SLKCFLAGS" \
./configure \
@@ -90,11 +90,25 @@ CFLAGS="$SLKCFLAGS" \
--localstatedir=/var \
--enable-gc=system \
--enable-offscreen \
+ --disable-lsp \
+ --disable-gc-debug \
+ --disable-gc-full-debug \
--with-latex=/usr/share/texmf-dist/tex/latex \
--with-context=/usr/share/texmf-dist/tex/context \
--datarootdir=/usr/share/texmf-dist \
--build=$ARCH-slackware-linux
+# To build the complete docs, some packages from texlive-extra are required.
+if [ $DOC = no ]; then
+sed -i doc/Makefile \
+ -e "s/ latexusage.pdf//g" \
+ -e "s/pdflatex latexusage//g" \
+ -e "s/ asymptote.pdf//g" \
+ -e "/pdflatex CAD/d" \
+ -e "s/CAD.pdf//" \
+ -e "s/TeXShopAndAsymptote.pdf//"
+fi
+
make
make check
make install DESTDIR=$PKG
@@ -119,15 +133,17 @@ find $PKG/usr/man -type f -exec gzip -9 {} +
for links in $(find $PKG/usr/man -type l ) ; do ln -sf $( readlink $links ).gz $links.gz;rm $links;done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-mv BUGS ChangeLog INSTALL LICENSE LICENSE.LESSER README TODO \
+mv BUGS ChangeLog LICENSE LICENSE.LESSER README TODO \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-cd $PKG/usr/info
-find . -type f -exec gzip -9 {} +
-for links in $(find . -type l ) ; do ln -sf $( readlink $links ).gz $links.gz;rm $links;done
+find $PKG/usr/info -name '*.info*' -type f -exec gzip -9 {} +
+for links in $(find $PKG/usr/info -type l ) ; do ln -sf $( readlink $links ).gz $links.gz;rm $links;done
mkdir $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+cat $CWD/douninst.sh > $PKG/install/douninst.sh
+
cd $PKG
/sbin/makepkg -p -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/office/asymptote/asymptote.info b/office/asymptote/asymptote.info
index 1a9aed22d3773..ae2a643fced18 100644
--- a/office/asymptote/asymptote.info
+++ b/office/asymptote/asymptote.info
@@ -1,10 +1,10 @@
PRGNAM="asymptote"
-VERSION="2.70"
+VERSION="2.85"
HOMEPAGE="https://asymptote.sourceforge.io/"
-DOWNLOAD="https://downloads.sourceforge.net/asymptote/asymptote-2.70.src.tgz"
-MD5SUM="b57e685568a7cca69024a86c7276eb6d"
+DOWNLOAD="https://downloads.sourceforge.net/asymptote/asymptote-2.85.src.tgz"
+MD5SUM="063786b8914f718d3bccf9d9168458f1"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="glm"
MAINTAINER="Johannes Schoepfer"
-EMAIL="slackbuilds at schoepfer dot info"
+EMAIL="slackbuilds@schoepfer.info"