aboutsummaryrefslogtreecommitdiff
path: root/office/wps-office
diff options
context:
space:
mode:
authorB. Watson <urchlay@slackware.uk>2023-06-27 03:32:50 -0400
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-07-08 16:41:58 +0700
commit7ddc750f57cc2fda37d06048f90ee8207398d569 (patch)
tree785414f06125f1cc04ce198ede0aee875443445c /office/wps-office
parent8e126f5be69ccea33041520c90afa6afc5534477 (diff)
office/wps-office: Install shared libraries +x.
Signed-off-by: B. Watson <urchlay@slackware.uk> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'office/wps-office')
-rw-r--r--office/wps-office/wps-office.SlackBuild16
1 files changed, 11 insertions, 5 deletions
diff --git a/office/wps-office/wps-office.SlackBuild b/office/wps-office/wps-office.SlackBuild
index 989c684bc9fc..693893ee3ba4 100644
--- a/office/wps-office/wps-office.SlackBuild
+++ b/office/wps-office/wps-office.SlackBuild
@@ -23,11 +23,14 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20230627 bkw: Modified by SlackBuilds.org, BUILD=3:
+# - install all shared libaries with +x permission.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=wps-office
VERSION=${VERSION:-11.1.0.11698.XA}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-3}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -67,9 +70,9 @@ tar xvf data.tar.xz
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} + -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} +
# No WPS submenus, automatic file associations or redundant fonts (DejaVuMathTeXGyre.ttf)
cp -a opt $PKG
@@ -84,8 +87,11 @@ cp -a usr/share/icons/hicolor/48x48/mimetypes/wps-office2019-* $PKG/usr/share/pi
chmod 0644 $PKG/usr/share/pixmaps/wps-office2019-*
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+find $PKG -print0 | xargs -0 file -m /etc/file/magic/elf \
+ | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : > .tmpfind.$$
+xargs strip --strip-unneeded < .tmpfind.$$ 2> /dev/null || true
+xargs chmod 755 < .tmpfind.$$ 2> /dev/null || true
# Thanks to NixOS (https://github.com/NixOS/nixpkgs/blob/master/pkgs/applications/office/wpsoffice/default.nix)
# distribution is missing libkappessframework.so, so remove the following dead libraries