aboutsummaryrefslogtreecommitdiff
path: root/office/wps-office/wps-office.SlackBuild
diff options
context:
space:
mode:
authorPetar Petrov <slackalaxy at gmail dot com>2023-05-01 19:27:33 +0100
committerWilly Sudiarto Raharjo <willysr@slackbuilds.org>2023-05-06 08:28:24 +0700
commit293d8b125b2550f3a1e9c50f4e669922e420f1b8 (patch)
tree9c3a5bdec9ec282a200e7b91e7c4635bf96a0475 /office/wps-office/wps-office.SlackBuild
parentf69fff53a077afeafac71d8343c1f000909d34a5 (diff)
downloadslackbuilds-293d8b125b2550f3a1e9c50f4e669922e420f1b8.tar.xz
office/wps-office: Updated for v 11.1.0.11698.XA. New maintainer.
Signed-off-by: bedlam <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'office/wps-office/wps-office.SlackBuild')
-rw-r--r--office/wps-office/wps-office.SlackBuild48
1 files changed, 34 insertions, 14 deletions
diff --git a/office/wps-office/wps-office.SlackBuild b/office/wps-office/wps-office.SlackBuild
index 5d6dd39e54b5..729769d8e7e4 100644
--- a/office/wps-office/wps-office.SlackBuild
+++ b/office/wps-office/wps-office.SlackBuild
@@ -2,6 +2,7 @@
# Slackware build script for wps-office
+# Copyright 2023 Petar Petrov, slackalaxy at gmail dot com
# Copyright 2016 Andre Fernando, Indonesia
# All rights reserved.
#
@@ -25,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=wps-office
-VERSION=${VERSION:-11.1.0.10920.XA}
+VERSION=${VERSION:-11.1.0.11698.XA}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -50,13 +48,10 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-SRCVER=${VERSION}
-
-case "$ARCH" in
- i?86) SRCARCH=i386 ;;
- x86_64) SRCARCH=amd64 ;;
- *) printf "\n\n$ARCH is not supported.\n"; exit 1 ;;
-esac
+if [ "$ARCH" != "x86_64" ]; then
+ printf "\n\n$ARCH is not supported... \n"
+ exit 1
+fi
set -e
@@ -66,9 +61,9 @@ cd $TMP
rm -rf $PRGNAM
mkdir -p $PRGNAM
cd $PRGNAM
-ar -x $CWD/${PRGNAM}_${SRCVER}_${SRCARCH}.deb
-tar xvf data.tar.xz -C $PKG
-cd $PKG
+ar -x $CWD/${PRGNAM}_${VERSION}_amd64.deb
+tar xvf data.tar.xz
+
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -76,9 +71,34 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# No WPS submenus, automatic file associations or redundant fonts (DejaVuMathTeXGyre.ttf)
+cp -a opt $PKG
+
+mkdir -p $PKG/usr
+cp -a usr/bin $PKG/usr
+
+# use our desktop files
+mkdir -p $PKG/usr/share/{applications,pixmaps}
+cp --no-preserve=mode,ownership $CWD/desktop/*.desktop $PKG/usr/share/applications
+cp -a usr/share/icons/hicolor/48x48/mimetypes/wps-office2019-* $PKG/usr/share/pixmaps
+
+chmod 0644 $PKG/usr/share/pixmaps/wps-office2019-*
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+# Thanks to NixOS (https://github.com/NixOS/nixpkgs/blob/master/pkgs/applications/office/wpsoffice/default.nix)
+# distribution is missing libkappessframework.so, so remove the following dead libraries
+rm -r $PKG/opt/kingsoft/wps-office/office6/addons/pdfbatchcompression
+
+# make ldd happy
+mkdir -p $PKG/etc/ld.so.conf.d
+echo "/opt/kingsoft/wps-office/office6/" > $PKG/etc/ld.so.conf.d/$PRGNAM.conf
+echo "/opt/kingsoft/wps-office/office6/addons/kcef/" >> $PKG/etc/ld.so.conf.d/$PRGNAM.conf
+echo "/opt/kingsoft/wps-office/office6/addons/cef/" >> $PKG/etc/ld.so.conf.d/$PRGNAM.conf
+echo "/opt/kingsoft/wps-office/office6/addons/kpromeprocesson/" >> $PKG/etc/ld.so.conf.d/$PRGNAM.conf
+echo "/opt/kingsoft/wps-office/office6/addons/krecentfile/" >> $PKG/etc/ld.so.conf.d/$PRGNAM.conf
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild